V PC nevidím TurrisNAS


#1

Zdravím,
opět se na vás obracím s prosbou o pomoc. Dle rad z fóra a návodu z webové dokumentace jsem z flash disku a Omnie vytvořil jednoduchý NAS. Ten se snažím nají v průzkumníku v PC s Win 10, ale nejde mi to, nikde tam není.

Na PC (PC1) je OS Win 10 Pro 64bit verze 1809 a jeden účet uživatele, připojeno do LAN je přes Wi-Fi.
Pokoušel jsem se podle některých návodů nastavit sdílení souborů, ale to nepomohlo. Síť mám nastavenu jako privátní a zjišťování sítě mám zapnuté, přesto PC v síti NAS ani druhé PC nevidí.
Při procházení příspěvků tady na fóru jsem pochytil nějaké příkazy, tak pro začátek přikládám jejich výpisy:

root@turris:~# cat /etc/config/fstab

config global
        option anon_swap '0'
        option anon_mount '0'
        option auto_swap '1'
        option auto_mount '1'
        option delay_root '5'
        option check_fs '0'

config mount
        option enabled '1'
        option device '/dev/sda1'
        option target '/mnt/nas'
        option enabled_fsck '1'

root@turris:~# mount

/dev/mmcblk0p1 on / type btrfs (rw,noatime,ssd,space_cache,commit=5,subvolid=256,subvol=/@)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
none on /sys/fs/cgroup type cgroup (rw,relatime,cpuset,cpu,cpuacct,blkio,memory,devices,freezer,net_cls,pids)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
/dev/sda1 on /mnt/nas type ext4 (rw,relatime,data=ordered)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
mountd(pid2425) on /tmp/run/mountd type autofs (rw,relatime,fd=5,pgrp=2423,timeout=60,minproto=5,maxproto=5,indirect)
/dev/sda1 on /tmp/run/mountd/sda1 type ext4 (rw,relatime,data=ordered)

root@turris:~# df

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mmcblk0p1         7633920    427236   7213856   6% /
tmpfs                   515364      3780    511584   1% /tmp
tmpfs                      512         0       512   0% /dev
/dev/sda1              7674328     34548   7230232   0% /mnt/nas
/dev/sda1              7674328     34548   7230232   0% /tmp/run/mountd/sda1

PS C:\WINDOWS\system32> ipconfig

Windows IP Configuration


Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Připojení k místní síti* 26:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Připojení k místní síti* 27:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : lan
   IPv6 Address. . . . . . . . . . . : fdc1:fce4:64d3::6fa
   IPv6 Address. . . . . . . . . . . : fdc1:fce4:64d3:0:ed17:f5e3:9772:27ae
   Temporary IPv6 Address. . . . . . : fdc1:fce4:64d3:0:c805:bf7b:2f4e:4557
   Link-local IPv6 Address . . . . . : fe80::ed17:f5e3:9772:27ae%3
   IPv4 Address. . . . . . . . . . . : 192.168.1.120
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter vEthernet (Default Switch) 2:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::8804:fbe:3e05:8c7a%44
   IPv4 Address. . . . . . . . . . . : 172.17.27.177
   Subnet Mask . . . . . . . . . . . : 255.255.255.240
   Default Gateway . . . . . . . . . :

Teď jsem ještě zkusil přístup do NASu z druhého PC (PC2). Na PC je OS Win 10 64bit verze 1803 a celkem tři účty pro tři uživatele. Je připojené UTP kabelem a NAS v průzkumníku ve složce Síť vidím, ale nemůžu v něm nic měnit. Při pokusu o vytvoření nebo smazání složky, nebo uložení souboru mi PC oznámí že nemám práva.
Z tohoto druhého PC vidím v průzkumníku ve složce Síť i první PC, ale při pokusu o jeho otevření dostanu oznámení že Windows nemůže získat přístup. Po klepnutí na tlačítko Diagnostika v okně s oznámením proběhne zjišťování problémů s výsledkem:

Nalezené problémy

Zařízení prostředek pro sdílení souborů a tisku (DESKTOP-HP) je online, ale neodpovídá na pokusy o připojení.

Podrobnosti o zjištění
Vzdálený počítač neodpovídá na připojení na portu 445. Pravděpodobnou příčinou je nastavení brány firewall, nastavení zásad zabezpečení nebo dočasná nedostupnost počítače. Systém Windows nenalezl žádný problém s bránou firewall v počítači._

Ještě pro info, k routeru je přes Wi-Fi připojená tiskárna, která z obou PC tiskne normálně.

Potřeboval bych provést nějakým postupem jak se z PC1 dostat do NASu na routeru, a z PC2 aby se dalo s NASem pracovat. Snažil jsem se sám nějaký návod najít, ale zatím jsem nijak nepokročil. Buď to na mně bylo bez dalšího vysvětlení moc složité a nebo v angličtině a tu neovládám. Původně jsem si myslel že to až tak složité s tím NASem nebude, začátek mi s pomocí fóra a dokumentace celkem šel, ale asi jsem se přecenil.
Přinejhorším mně můžete poslat do háje, ať si na to někoho pozvu, nebo kopím hotový NAS.

P.S.
Pokusil jsem se příspěvku dát nějakou formu, jako jsem viděl tady na fóru. Ale tohle prostředí fóra ještě tolik neznám a ze začátku jsem ho mněl v angličtině, než jsem našel že jde přepnout do češtiny. Nenašel jsem ani že by šel příspěvek před odesláním zobrazit v náhledu, abych si mohl případně vyzkoušet jak volby úprav fungují a jak se promítnou do odeslaného příspěvku, takže jsem se sice pokusil, ale výsledek vypadá jinak než jsem chtěl.


#2

Nedávám žádnou odbornou radu … jen obrázkovou inspiraci :-). Router musíte vidět v síti vždycky, pokud ne - není to problém routeru a ni sdílení. Mně jako laikovi dělala vždy problém windousí příšernost zvaná “domácí skupina”, které vůbec nerozumím. Tu nikdy nepovoluji.
Až uvidíte router — pak nasdílíte potřebný adresář. Veškerá nastavení děláte z Foris a Luci. S vyjímkou příkazu, kterým se případně povolí na sdílené místě i zápis.

Osobně považuji za vhodnější aktivovat ve Foris “Storage” a následně všechny cesty připojovat přes /srv/ (a všude jinde kde bylo nějaké /sda/xxx nebo /sda1/rrd/)

d


#3

Dle logu jde vidět, že se disk připojuje do dvou složek.
Zkuste zakázat automatické spuštění mountd a resetujte router.


#4

Při pátrání po řešení jsem někde na webu Microsoftu četl že ve Win 10 už “domácí skupina” není přítomna a sdílení je možné jenom s konkrétní osobou. Taky při pokusu o povolení sdílení s domácí skupinou se nic nestane.

Úložiště (Storage?) ve Forisu je a bylo aktivováno bez mého přičinění. Proto mám taky /dev/sda1 přimountováno 2x. Při nastavování v Omnii jsem dodržel návod, ale jak jsem zjistil tak v některých věcech neodpovídá tomu jak se TurrisOS chová a jak jsou pojmenovaná některá nastavení. Ale nastavit to podle toho šlo.

Zkusím radu od czlada a uvidím.


#5

Storage se samo neaktivuje nikdy! Vždy to musíte udělat manuálně. Disk se přitom zformátuje. Pokud je aktivní, již na stejné medium nesmíte dát další přípojný bod, pak vznikají kolize a fleška se odpojuje. Ostatně žádné /srv/ u vás nevidím. První si vyřešte Windows a viditelnost routeru v síti a řešte potom sdílení. Všechny operace dělejte z Foris a Luci. Nejlepší by bylo vrátit se schnappsem do stavu, než jste do toho začal zasahovat manuálně.


#6

Zde https://doc.turris.cz/doc/cs/howto/nas je kompletní návod, jak to sprovoznit. Aby Win10 viděly NAS (protože microsoft přestal podporovat netbios), musí se ještě doinstalowat WS-Discovery:

opkg update
opkg install wsdd2
/etc/init.d/wsdd2 enable
/etc/init.d/wsdd2 start

a pokud máte formát disku NTFS - situace je o to ještě složitější.

EDIT: Jasně, teď vidím formát ext4 - v pořádku. Momentálně je automountem přimontován v adresáři:
/tmp/run/mountd/sda1

Teď si nastavte a aktivujte sambu (to je to sdílení).
Pro jistotu sem dám ještě odkaz na jedo vlákno:

Dost se to řešilo i tady:


#7

Odškrtnul jsem v LuCI v “Systém > Přípojné body” automount SWAP i FileSystem a restartoval, přesto se mi disk pořád mountuje i do /tmp/run/mountd/sda1. Jako přípojný bod jsem podle návodu zadal pouze /mnt/nas, jinam ne.
S tím storage máte pravdu, nějak jsem to popletl.
Podle toho návodu v odkazu jsem právě postupoval.
Formátování se mi povedlo přímo v Omnii na ext4. Probíral jsem to tady na fóru, to jste asi našel. Ten automount nevím kde ještě zrušit.
Vlákna pročtu a až to všechno udělám dám vědět jak jsem dopadl.

EDIT: Sambu jsem kontroloval podle návodu, ta byla povolená, ale asi jsem ještě neklepl na start, tak to udělám.


#8

Aby jste zrušil automount, lze zakázat službu v LuCI: Systém - Po spuštění, lze i přikazem:

/etc/init.d/mountd disable && reboot

Zpět žaškrtněte ty volby v Přípojných bodech a v těchto Přípojných bodech použíjte průvodce přípojným bodem (doporučuje se připojit do adresáře /mnt - dle návodu), až to provedete, budete moct nastavit si sambu.


#9

Teď provádím ty příkazy instalující WS-Discovery, až to bude provedu budu pokračovat zrušením automountu podle toho jak píšete. Podle návodu jsem postupoval a disk se mi tedy mountuje i do /mnt/nas, je to vidět i ve výpisech příkazů výše.


#10

jj, už to vidím, pardon, pak tedy sačí vypnout automount (mountd).


#11

Hlásím pozitivní změnu. Po provedení příkazů a restartu Omnie už NAS vidím i z PC1. Ale jmenuje se jinak než jsem podle návodu zadal. Do “Název počítače” v síťovém sdílení jsem zadal “TurrisNAS” a tak se mi předtím taky hlásil na PC2. Teď se na obou hlásí jako “turris”, přičemž v kolonce je stále napsáno “TurrisNAS”. Ani z jednoho PC zatím nemám do NASu přístup, ale ještě jsem nepročítal ty vlákna.


#12

Výborně, tak teď si změňte název v sambě (Síťová sdílení) a na zkoužku si povolte hosté.

EDIT: Ten název turris si bere z DNS a tak se asi jmenuje Váš router (to je právě ta problematika Win10, protože už nepoužívají pro zjištění jména netbios, ale DNS (nebo za subnetem WINS)).


#13

Další poznatky:
Název jsem přepsal stejným názvem “TurrisNAS”, zatržítko “Povolení hosté” jsem odtrhl a zatrhl a dal “Uložit & použít” a provedl restart. A stalo se následující:
Na PC1 stále jméno “turris”, asi proto jak píšete a přístup nemám.
Na PC2 (má starší verzi W10) se objevil NAS 2x. První se jménem “turris” a bez přístupu, druhý se jménem “TURRISNAS” s přístupem do složky “Multimedia” (jméno podle příkladu v návodu). Složka obsahuje podsložku “lost+found” a do té přístup nemám a nemůžu jí ani smazat. Do složky “Multimedia” nemůžu nic zapsat.


#14

Momentálně nevím, jakou sambu používáte (samba 3 nebo již nová samba 4) a zde se budou lišit konfigy pro sambu. Já testuji TOS4 (Turris OS4 - tesovací verze) a na Omnii NAS nepoužívám, tak s tím Vám již bohužel neporadím. Osobně bych začal bez práv uživatele (to jsou ti hosté a odháčkovat pouze pro čtení) a až se dostanete do zápisu do složek, prováděl bych uživatelské účty. Zkuste Maxovy poznatky k smb.conf viz. odkaz víše (nejprve si ale zazálohujte originál konfiguraci).


#15

Nevím zda neopakuji již známé: po provedení všech kroků Foris a Luci

/etc/init.d/samba enable
/etc/init.d/samba start

chmod 777 -R /mnt/sda/share … práva pro zápis do sdíleného adresáře


#16

Na mé Omnii je TurrisOS 3.11.2 V nainstalovaných balíčcích jsem našel samba36-client, samba36-server oboje verze 3.6.25-11. “Povolení hosté” mám ztržítko, “Pouze pro čtení” zatrženo nemám, přesně podle návodu. Sambu povolenou a spuštěnou mám. Chmod… v návodu nebyl, nebyl proto ani proveden. Provedu.


#17

Samba mu již běží (vidí složku "lost+found), ale ty práva na tu složku, to jsem nevěděl.


#18

Ten příkaz jsem zadal a něco mu asi chybí, či co, toto mi odpověděl:

chmod: unrecognized option: /
BusyBox v1.29.3 () multi-call binary.

Usage: chmod [-R] MODE[,MODE]… FILE…

Each MODE is one or more of the letters ugoa, one of the
symbols ±= and one or more of the letters rwxst

    -R      Recurse

#19

Návod i to co psal @JardaB jsou jen příklady, ve Vašem případě to bude vypadat asi takto:

chmod 777 -R /mnt/nas
chmod 777 -R /mnt/nas/Multimedia


#20

Nezapomeňte na sambu také vložit 777 pro Vytvoření masky i pro Masu adresáře dle screenu od @JardaB