Using HaaS with Omnia

I try to set up the data collector with the HaaS. The documentation says that my login credentials for the HaaS website are the same as the credentials for Turris. But in my case, this isn’t. A login attempt on HaaS says that the credentials are invalid. I created a new account on HaaS with the same login email address, but it has no connected devices after that.

I could need some help with associating my Omnia with the HaaS service please

you know this doesn’t help us and it doesn’t answer, what @simonszu asked, right?
Because right now I read your posts in Czech section and in other two threads in English section. Please keep forum organized or I’ll hide your post here.

Please understand that forum is not the right place for reporting bugs.
For reporting bugs, please send us e-mail to or create ticket here. To this matter I’ll tell you more on Monday. We take security reports very seriously.

Anyway let’s answer @simonszu issue.
Create new device on HaaS website (if you dont already have it). If you have it then you copy token and paste it to option token in file /etc/config/haas.

I copy the token to file /etc/config/haas, but Haas dont work. Also I must copy token to file /etc/config/haas-opkg ?
On Haas website by my device isnt ID. Its right?

@Pepe thank you. I have done as you said. However, on the last line says: “If you want to use HaaS with your Turris, just enable SSH honeypot in Updater tab in the administration interface called Foris. Everything else will work automatically and you will be able to use the same login as for Project Turris.”

As you see, everything else will not work automatically, at least you have to create the device and copy the token. If you will update this documentation, i am sure less threads like this one will pop up.

@homberg No, just use /etc/config/haas. The files ending in -opkg are placed there by opkg, if it detects that the original file has changes made, so it won’t overwrite your changes and you are able to manually insert the maybe new declarations in the -opkg file into your original file.

I was wondering how you found this. After reading your post, i was looking at my firewall configuration in LuCI and to my surprise there was no rule to allow incoming traffic to port 22 on the router at all. A quick check by trying to connect to my router from the outside revealed that the port was indeed closed, and that there was no honeypot listening there. Doesn’t activating the honeypot in Foris UI automatically open the according port to the router?

Of course, the general firewall setting for INPUT of my WAN zone is set to deny.

After selling the Omnia internationally, these Czech sections in the forums are clearly not helpful and should be set to read-only, imho