User experience - ALLNET ALL4781-VDSL2-SFP / Switch Modul (Mini-GBIC), VDSL2


#61

Ran a tcpdump on eth0 and eth1 and both reporting receiving the packets from the monitor app but there it ends - no response from eth1 on the matter

That is what the packet looks like

Summary

Frame 8905: 64 bytes on wire (512 bits), 64 bytes captured (512 bits)
Encapsulation type: Ethernet (1)
Arrival Time: removed
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1545232779.207710000 seconds
[Time delta from previous captured frame: 0.016714000 seconds]
[Time delta from previous displayed frame: 0.000000000 seconds]
[Time since reference or first frame: 113.423201000 seconds]
Frame Number: 8905
Frame Length: 64 bytes (512 bits)
Capture Length: 64 bytes (512 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: eth:ethertype:data]
Ethernet II, Src: HonHaiPr_ba:be:5f (b0:10:41:ba:be:5f), Dst: Allnet_15:76:40 (00:0f:c9:15:76:40)
Destination: Allnet_15:76:40 (00:0f:c9:15:76:40)
<[Destination (resolved): Allnet_15:76:40]>
Address: Allnet_15:76:40 (00:0f:c9:15:76:40)
<[Address (resolved): Allnet_15:76:40]>
… …0. … … … … = LG bit: Globally unique address (factory default)
… …0 … … … … = IG bit: Individual address (unicast)
Source: HonHaiPr_ba:be:5f (b0:10:41:ba:be:5f)
<[Source (resolved): HonHaiPr_ba:be:5f]>
Address: HonHaiPr_ba:be:5f (b0:10:41:ba:be:5f)
<[Address (resolved): HonHaiPr_ba:be:5f]>
… …0. … … … … = LG bit: Globally unique address (factory default)
… …0 … … … … = IG bit: Individual address (unicast)
Type: Unknown (0x6120)
Data (50 bytes)
Data: 0007016c360000004f220000000000000000000000000000…
[Length: 50]

That seems the end of the road I am afraid. Unless the developers would kindly implement a mechanism to pass those packet through to the modem and returning packets to the monitor app like it is works in switch devices.


#62

@renne: If you get the DSLAK.dll loading error, do you have the WinPCAP LIbrary/Utility installed on your Windows System? I just installed the DSLMonitor on my Machine and hit the same error, but once I had winpcap installed the error was gone. n8v8r probably had it installed already as part of the Wireshark Installation.

Now I have hit the same problem as n8v8r… I bridged the Interfaces together on the turris, but no connection is possible. I’ll try to get my hands on a switch with an SFP Port, but don’t know how soon I’ll be able to get one.


#63

indeed. Good find :+1:


#64

NPCAP with WinPCAP capability mode does the trick for me. :smile:


#65

With the schematic WAN/SFP -> eth1 it should not be necessary to manipulate the eth1 mac with the modem’s mac but rather use the eth1 mac in the monitor app -> Device Mac = eth1 mac


#66

So, I got myself a Switch with SFP (ebay) and it works as advertised. Here are some Screenshots:



Also here is the Dump: https://cloud.s-brand.de/s/Q4a3LmKc449YXeH/download

Values actually look pretty similar to the ones my External Draytek Router/Modem uses, the Actual Downstream Rate shown in the overview at 79593 on the Allnet is actually quite a bit Lower than on the Draytek (98338)


#67

At least modem owners are now able to exchange the modem’s telemetry with the ISP. Too bad it requires the investment in another switch device.


#68

From the the dump the failure of

Showtime Full Inits

is apparent. If not mistaken that represents the TC sync status with the ATM.


#69

While the dump was in progress the modem didn’t have DSL sync (it had sync before the start of the dump and resynced sucessfully once the dump was done). No idea if that is intentional behaviour or not.


#70

It might switch into some sort of promiscuous mode during the dump in order to be able to gain access to some particular line parameters.


#71

@seiichiro0185 Adding ports 2 3 4 in the monitor app is providing more/additional data?

With the EBM booting function is possible to boot the modem with another firmware than the one installed in the modem?


#72

Enabling the other ports doesn’t change anything. They are selectable at the top, but don’t show any additional data
After enabling the EBM Boot Option I tried selecting one of the Files from the “firmware” folder, but couldn’t. Even tried to rename one to *.b so I could select it, but trying to connect showed an error and then the Module connected with the Flashed Firmware, not with the selected one


#73

Maybe the app carries the Lite tag for a reason, i.e. being stripped of some features :slightly_frowning_face:


#74

I can confirm DSLmonitor-Lite works with a TP-Link MC220L media converter.

I observed the same behavior like @seiichiro0185 when doing a SOC dump.

The chain ALL4781 -> MC220L -> Fritz!box 7490 shows the same VDSL-sync losses like the ALL4781 with Turris Omnia.

SOC-dump


Various (driver) issues
#75

@renne @seiichiro0185

Did you, or are you planning to, share the dumps with the ISP and ALLNET to figure the connectivity issues?


#76

I already sent the dump to Gerhard Zerwes (Allnet).
Telekom standard slogan: It’s your equipment, not our socket."


#77

Unfortunately got more or less the same response from my ISP (1&1) “You’re not using our supplied router, so you are on your own. All looking good on our end”


#78

Hello,
I have no success with SFP yet, but I now tried an external Modem successful:
https://www.allnet.de/en/allnet-brand/produkte/modems-router/modems-adsl/p/allnet-all0333cj-adsladsl2-modem-annex-b-und-j/
I have 14.6 MBit download and 1.6 MBit upload.
This is my configuration.

onfig interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0 eth2’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr ‘192.168.1.1’

config interface ‘wan’
option ifname ‘eth1.7’
option ipv6 ‘auto’
option keepalive ‘5 5’

config interface ‘wan6’
option ifname ‘@wan
option proto ‘pppoe’
option username ‘U@t-online.de’
option password ‘PW’
option ipv6 ‘auto’

config switch
option name ‘switch0’
option reset ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0 1 2 3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘4 6’
option vid ‘2’


#79

Yeah, that’s german services. 1und1 has to rent the last mile from Telekom. So they pass through the Telekom answer and add their subtle “rent our router” message.


#80

@SteJe, accoding to the working external modem, your Connection is an ADSL2+ Line, not a VDSL2 one. Since the ALL4781 SFP is only specified for VDSL2 and not for ADSL, it will not work with your current DSL Line. That also corresponds to the PADO Timeouts (meaning no DSL Sync most probably) from the Log you posted earlier. So unless you can get a VDSL2 Line at your place (50MBit or higher should normally be VDSL2) the SFP won’t work unfortunately.