Use other DHCP server on LAN than Omnia


sorry for basic question but not able to find a solution.

I have historically configured DHCP and DNS on Synology NAS, where I would like to keep them. Unfortunately after change of router to Turris Omnia DHCP assignment on clients stopped working. When I manually configure client everything works =>problem is probably in DHCP broadcast/relay inside br-lan group (eth0, eth2 and both wireless networks)

I have found in LuCi under menu Network -> DHCP and DNS option “Authoritative” Which I have switched off. Unfortunately haven´t found anything else what will influence behavior.

Any ideas how to make it work?

Thanks in advance


Disable DHCP on Interface (Netw. -> Interfaces -> LAN -> Edit -> DHCP Server (bottom) - or turn off dnsmasq completely.

Hi Ruff,
thanks for support. DHCP was already disabled (set up during initial config). dnsmasq I have disabled based on your suggestion in System -> Startup and verified that is not listed in running processes.
Unfortunately it didn´t helped.

What you can do, is try to isolate each one of them.

So first, try to have your clients (using DHCP) only with the Omnia in a separate network, using for example a switch or just the Omnia it self. See if they get an ip-address at all. Which you then can confirm if the DHCP indeed is off.

If it indeed is off, look if you can find somewhere the whole relay/bridge stuff.

Or even more hardcore, just delete those(DHCP/DNS)…in your package system. So they are no longer installed.

Then most probably it has nothing to do with dhcp. Perhaps there’s something else. To prove that you may run tcpdump to ensure omnia is not participating in dhcp

tcpdump -eni br-lan -c10 port 67 or port 68

this will show dhcp exchange seen on lan interface. Check that mac addresses in the capture do not correspond to those of omnia interfaces.

Thank for adwises. I will try to make a factory reset (4th in a row) and configure it outside current environment. Also meanwhile after connecting old router I have realized that DHCP somehow stopped to work - so first is to make it work again.

Sorry for missleading I didn´t expect that it will stop work at same time when I will change router (epecially when it worked for 1,5 year without problems). Also I wil point my investigation to the situation when static set-up of IPv4 in Win10 lost ability to connect to network - this client is connected to Omnia via Linksys Switch while directly connected client (also Win10 with static IP configuration) worked OK.

It will take some time as I don´t have much time to play with it. When I found something I will let know results for information.

thanks again and sorry for misleading.

After return of original router I have found, that initial issue is in DHCP server itself as Synology has/had bug in GUI. In fact there was some error which caused that DHCP reservations had conflicts (didn´t deleted old reservation) and indicated that it works fine and showed correct list. After fixes of config files on Synology directly it started to work.

Omnia configured outside the network with disabled DHCP worked after short time OK. I have switched off network switches to remove any rules and also IPs were stabilized for a day before router change. (During weekend config I have used IPs outside range managed by DHCP).

For the moment everything looks OK with basic config + few NAT rules.

Have a nice day


Hmmm @ruff, I looked on the processes page of my Omnia - no dnsmasq running, but I see odhcpd. According to openWRT’s site: odhcpd is a daemon for serving and relaying IP management protocols to
configure clients and downstream routers. This finding would seem to explain why I cannot find any dnsmasq configuration on my Omnia (a few lines all commented out - boilerplate), but raises the question why my router is running odhcpd for dhcp instead of dnsmasq. Thoughts anyone? Am I missing something that should be obvious?

Additional info: I terminated the odhcpd process, but it was restarted even though I’ve told dhcp via LuCi to ighnore all of the interfaces. Looking at installed packages, I see both dnsmasq, odhcp6c and odhdcpd.