USB Wifi Ralink RT2870/RT3070 stopped working after turris upgrade


my addiditional USB Wifi Ralink RT2870/RT3070 stopped working after turris upgrade of turris yesterday.

In LUCI or fortis it looks like USB Wifi is configured but not connected it show only this :
Generic MAC80211 802.11bgn (radio0) 0% SSID: Turris | Mode: Unknown
Wireless is disabled or not associated

Wifi detect > /etc/config/wireless create results but 2.4GHz wifi from Ralink dongle is not available on air.

At first it looked like malfunction of USB dongle but after testing it in another computer I come to conclusion that some software upgrade of turris os is to blame.

I tried also install different USB Wifi dongle with Atheros chipset that worked before but after try to install Atheros USB dongle kmod I get error that I don’t know how to fix :
Installing kmod-carl9170 (3.18.44+2016-10-08-4-93291736f4d5145ea9d62e8746031bf1-15) to root…

gives error Collected errors:
*** satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-carl9170:**
** * carl9170-firmware ***
*** opkg_install_cmd: Cannot install package kmod-carl9170.**

This is known problem of missing firmware packages.

You can resolve it by downloading and installing manually from the nightly branch:

Thank you for advice, I will try to install given package from your link. But as Atheros wifi dongle was not as stable as Ralink one on turris I would like to make that Ralink WIFI USB working again at the first place.After upgrade it looks like it should work but as I wrote no 2.4GHz network from this USB dongle on air…

UPDATE: There was obviously some garbage configuration problem or whatever. Yesterday second wifi malfunction forced me to wipe my Turris 1.0 NAND and flash actual image from SD card. After reinstallation it seems like 5Ghz internal wifi is working without interruptions and external Ralink WIFI USB dongle started working back again. So fresh installation solved my problem.

I done
opkg update
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb

to make USB wifi working again.