USB devices aren't working

turris1x

#1

Hi,

I’ve recently noticed that whatever I plug into USB isn’t recognized (ext. HDD, printer, TV tuner). It works a few days ago without any problem. I’ve tried to unplug/plug them again, watching udev messages, but there wasn’t nothing interesting. Interchange of USB ports didn’t help as well.

I’m afraid that USB controller in Turris died…

Turris version 1.0

root@turris:~# uname -a
Linux turris 4.4.113-56ef06674a2579d8488bcbf4fe98e926-1 #1 SMP Mon Jan 29 12:51:41 CET 2018 ppc n

Udev log:

root@turris:~# udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent
KERNEL[10672.021739] remove   /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[10672.021825] remove   /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[10672.021884] remove   /devices/virtual/net/tun1 (net)
KERNEL[10681.312875] add      /devices/virtual/net/tun1 (net)
KERNEL[10681.312946] add      /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[10681.312988] add      /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[10922.079756] remove   /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[10922.080736] remove   /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[10922.080834] remove   /devices/virtual/net/tun1 (net)
KERNEL[10931.321948] add      /devices/virtual/net/tun1 (net)
KERNEL[10931.322024] add      /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[10931.322067] add      /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[11171.248888] remove   /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[11171.248942] remove   /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[11171.249958] remove   /devices/virtual/net/tun1 (net)
KERNEL[11180.529147] add      /devices/virtual/net/tun1 (net)
KERNEL[11180.529200] add      /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[11180.529253] add      /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[11421.180969] remove   /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[11421.181058] remove   /devices/virtual/net/tun1/queues/tx-0 (queues)
KERNEL[11421.181112] remove   /devices/virtual/net/tun1 (net)
KERNEL[11430.587323] add      /devices/virtual/net/tun1 (net)
KERNEL[11430.587388] add      /devices/virtual/net/tun1/queues/rx-0 (queues)
KERNEL[11430.587428] add      /devices/virtual/net/tun1/queues/tx-0 (queues)

Do you have any idea what did happen?

Thanks a lot!
Martin


#2

Hi, try to poweroff Turris and wait 10-15 minutes to let it cool down … I have also Turris 1.0 and after reboot my USB ports are not working … if I let it cool down, ports worked OK :slight_smile:


#3

Hi,
that’s only a workaround.

We can’t reproduce it. In other thread, I requested output from the serial console, but no one send it to us.
See here my respond in Czech (most users of Turris 1.x users are Czech people):


#4

Hi,
You are right, but I moved all USB devices to Omnia ( as I wrote in another thread ) and Turris USBs are not so important for me now to find time to play with it … but I will try to check it later - no promise, because of family and Turris as a main router …


#5

Hi, thanks for advise, I can send you the logs from serial console in next couple of weeks.


#6

Interesting… I didn’t have a chance to gather log from serial console yet. And it automagically works now. Maybe was caused by latest update, current kernel:

4.4.119-df8c454b3cdf471ca0ef3e4df07c2cb7-0