UPnP server not running?


I have a stock setup with the UPnP module installed (as it is out of the box). I haven’t touched any of the settings, so it’s enabled:

Start UPnP and NAT-PMP service ON
Enable UPnP functionality ON
Enable NAT-PMP functionality ON
Enable secure mode ON

I have the default port forwarding rules (high ports ALLOW, all ports DENY, in that order).

Except nothing on my network can actually see the server. Apparently there doesn’t seem to be one running. Doing a scan for UPnP servers shows nothing, and new redirections don’t appear in the Turris console. Nothing shows up in the logs. There is no /var/run/miniupnpd.leases file. There is no process with ‘upnp’ in the name.

(I do now notice that the ‘software’ tab thinks that miniupnpd is both installed and installable, with the same version, which looks suspicious.)

Any ideas?

/etc/init.d/miniupnpd enable
/etc/init.d/miniupnpd start

Thanks; it was turned off in /etc/config/upnpd. I enabled it and it’s working.

I haven’t played with my setup at all; I’m trying to keep it as much in its original state as possible. Why isn’t the Luci setting (which told me it was enabled) synced with the config setting in the text file? Shouldn’t this work out-of-the-box?

There is as little service as possible in the defaults, it is up to the user to let go and use it. in LuCI it is here: System - Startup

So what does the switch in the UPnP console labelled ‘Start UPnP and NAT-PMP service’ do, given that it doesn’t appear to start the UPnP and NAT-PMP service?

Depending on the extras, these features are used to link other services (the same print server service, etc.)

Sorry, could you expand? I don’t follow.

1 Like

in LuCI (System - Starup) is the main service control - via the ssh directory: /etc/init.d

If the service is enabled when restarting the router, it will have status Enable - via the ssh directory: /etc/rc.d

Then is specified (in our case UPnP and check box) for other purposes (other services) - via ssh edited file bold marked /etc/config/upnpd:

option enabled '1’
option enable_natpmp ‘1’
option enable_upnp ‘1’
option secure_mode ‘1’
option log_output ‘0’

That is, to have the service running, you must have Enable in both places - I would not discuss it further.

Okay, I understand now.

This is incredibly confusing. The checkbox in the UPnP page should not be labelled the way it is — having a checkbox labelled ‘Enable service’ which does not enable the service is not good UI.

I would suggest:

(a) change the label of the checkbox in the UPnP page. Something like ‘Configure miniupnpd to serve upnp requests’. Something which makes it clear that it’s not controlling the overall service state.

(b) have a big banner at the top of the UPnP page which says something like: ‘These settings affect the miniupnpd service, which is enabled or disabled through the System>Startup configuration page (with link). The current state of the service is: ENABLED/DISABLED’. (In fact, all the configuration pages for the various services should have this.)

1 Like

I’m not going to do anything about it, I’m only a user - Turris Team that has been taken from OpenWrt, the author is OpenWrt and it’s just the LuCI programmer (or a miniupnp programmer), you can put a suggestion to change it to OpenWrt Forum.

Oh, sorry, I thought you were customer support!