Upgrade to a wifi router

Hey there,

I’d like to add my Mox the modules/addons to turn it into a Wifi router.
I have a Mox with modules A + F (the Cloud set).

What should I buy to sort it out ?

Thanks

Hi @dadall,

you have following options to add WiFi functionality to your setup:

MOX Wi-Fi add-on (SDIO)

  • This module can be plugged to the module A - no additional module is needed
  • Can be used to create either 2.4 or 5 GHz WiFi network
  • People on this forum are reporting issues with this add-on when using the 5 GHz frequency

MOX Wi-Fi add-on (mPCIe)

  • This add-on offers better performance and I havent seen any complaints on this forum
  • Disadvantage: You need to buy additional modules (B or G) to connect it with your MOX

It is important to understand that none of the add-ons allows to create 2.4 and 5 GHz network at the same time. You need to have 2 add-ons to achieve this. In my case I have the SDIO add-on for 2.4 GHz network and mPCIe add-on seated in the G module for the 5 GHz network.

Next to that, you might be interested in modules C or E in order to add some RJ-45 ports for your wired devices.

Happy routing! :slight_smile:

1 Like

SDIO card can’t support multiple SSIDs.

1 Like

Thanks @viktor! I wasnt aware about this limitation. Another reason to go for mPCIe add-on.

Thanks @dkomrska @viktor! I know what to do now :slight_smile:

I have to warn you that I have quite a bad time running A+G+F configuration right now, as evidenced by my dmesg log: Modules G+F interoperability

It depends if you run a NAS on your MOX. If you do, just be aware of my warning.

Hey,

I ordered G + mPCIe when I saw the post from the other topic where you say it is fixed.

I’m confused because it works and vanish randomly. By vanishing I mean the G module is not loaded by the Mox while nothing changes… Seems to be a software issue…

Any idea ?

Hey there,

Update : the module seems to be loaded at every reboot now. Can’t be sure why it works but it’s cool. Maybe the last updates ?

Sadly, the Mox keeps rebooting twice a day, or more, when the Wifi network is used by multiple devices.

Nothing important from the logs can explain the issue.

I’m using the alternate wifi driver. The basic one makes the Mox the reboot every 45min when the wifi is used.

Turris OS 5.1.1 loaded but my Mox keeps randomly rebooting when the wifi is used.

Am I the only one facing this issue ?