Updating Turis : Nextcloud disappears

I haven’t updated my Turris Omnia router for months and decided to do it yesterday (Sept. 19).
I saw a really huge and long update happening, with various newtork interruptions and reboots.
The result seems to be a new, simplified interface, different from the previous basic one I used (not using LuCi), but above all, my local Nextcloud installation has disappeared. I now just get a 404 not found when going to the previous Nextcloud address and in the new interface I just do not see any way to interact with Nextcloud.
I tried to use again the old interface : I now have a really negative message, ‘deprecated’ announcing that things that I try here probably won’t work. And even from there I cannot ‘launch’ Nextcloud (I see the message ‘You already configured your Nextcloud, you can visit the site.’ which leads to the 404 not found) .
From my interface I see the following versions:
reForis 0.9.3
|Version Turris OS|5.1.0|
|Branche Turris OS|HBS|
|Version du noyau|4.14.193|
I don’t know what happened in the large update, but the feeling I retain is things are LESS simple to handle, and I lost my Nextcloud data. I am about to order a second Omnia for an installation in Paris but now I doubt :frowning:
I cannot even get back to the backup interface I previously had with the old onterface, that would allow me to gat back to the previous version -it seems this too has disappeared in the new interface!

I have the same problem. Turis 5.1, After installing Nextcloud via reForis, I only get a error 404.

Thank you vkolacek!
I can add it is not enough to

  • deinstall then reinstall Nextcloud
  • reformat the external disk (losing all stored data, I suppose)

I agree this package is flagged ‘experimental’, but such a behavior is a significant regression…
At the very least one would have appreciated a warning, to prevent Nextcloud users from updating…

And anyway : what can we try now?
Thank you!

Nobody reacts. I must have posted in the wrong forum again…

Hi @Herve_S,
I just created I small guide which helps to get Nextcloud running again after TOS upgrade from 3to5:

Have fun!

kind regards

Hi folks,

I just upgrade my Turris Omnia from TOS 6.0.3 to 6.0.4 and Nextcloud disappeared out of sudden. I only get a 404 when trying to reach the website.
Even a 'schnapps rollback ’ to the “Automatic pre-update snapshot” leaves my Turris Omnia with a 404 when trying to open nextcloud.

This seems to be a bigger problem since this happens over and over again when upgrading TOS… :frowning:

I hope someone from Turris Support Team reads this…

kind regards

Official support generally does not follow this community forum. There’s a different channel for that: Support - Turris Documentation

Without more details, it seems like your external device is not connected to your router or it is not mounted.

I’ve got also this problem sometimes on my Turris 1.1. My HDD is sometimes not mounted as SRV storage. I didn’t have any time for resolving this issue yet.

For my installation I can say that it is not caused by errornous external storage.
I too have no time to fix it right now. But I did a backup of the NC database and the nextcloud folder. What I was able to figure out is that: The nextcloud folder did not contain any *.php file anymore. Some TOS upgrade thing must have removed these files…
According to Nextcloud - Turris Documentation I manually tried to install NC again:

echo 'Install("nextcloud-install")' > /etc/updater/conf.d/nextcloud.lua

The latter command gave me some warnings (don’t remember details) that I concluded no success.
After that I decided to switch off nextcloud feature in reForis, just to enable it again. But after saving the ‘off’ checkmark my router told me about updates: Several PHP8 packages to install and some PHP7 packages to remove which I granted.
The 404 was Töne after that but now I get PHP error which leads me to a database not running (?) conclusion just before I ran out oft time…
Need to fix that after Christmas.

Wish you all a Merry Christmas!


Hello again,

after struggling with my Turris Omnia I installed my latest medkit backup from April/25th (It’s TOS 5.3.7, not 5.3.4 as told in the title of the dpaste link.) which leads me to a kind of running nextcloud installation. It says I need to upgrade my PHP version to a more recent PHP7 one.
At that point I tried to install the TOS upgrade again from secure shell which unfortunately leads me to the exact same Nextcloud PHP-error as before.
For me this is a reproduceable updater error.
Everything I could find about that PDO error was not helpful in my case. :frowning:
I don’t have any idea how to fix this.

So if anyone has a good idea how to get Nextcloud back running please leave an answer to this topic. :wink:

Kind regards

Some hours and several experiments later I got a clue how to fix the issue myself:

In my case the Nextcloud installer fails to execute post install scripts because of missing PHP libraries.
The installation itself warns about /etc/php.ini exists and got manual changes, the new PHP config file is written to /etc/php.ini-opkg. I’m not sure if I ever changed something on that file but who knows… :wink:
The essential difference is a line like extension_dir = "/usr/lib/php" which changed to extension_dir = "/usr/lib/php8". So cp /etc/php.ini-opkg /etc/php.ini did the trick for me. I needed to issue

cd /srv/www/nextcloud
sudo -u nobody php8-cli ./occ upgrade

to finish the Nextcloud installation properly.

Hope that information saves someone some time. :slight_smile:

Kind regards

1 Like

@ChrisPHL thank you very much for posting your solution! Chaning the /etc/php.ini also worked for me. Finished the upgrade to Nextcloud v23 afterwards via WebUI.

1 Like