Updating to openWRT 19.07.2

Hello Turris Family,

I have a quite strange Problem at the moment.

Currently i try to upgrade from the default Turris OS 4.0.5 to OpenWRT 19.07.2.
I followd the Method 1 on this Guide: https://openwrt.org/toh/turris/turris_omnia
And i also tried to upgrade it through the WebGui.
Everytime i get the same result.
It looks like everything went well but i dont get any ip adress on my clients.
Because of this problem i am not able to see through the config or anything.
For the Upgrade i used the following Image:

Firmware OpenWrt Upgrade URL:

http://downloads.openwrt.org/releases/19.07.2/targets/mvebu/cortexa9/openwrt-19.07.2-mvebu-cortexa9-cznic_turris-omnia-sysupgrade.img.gz

Has anybody an idea whats wrong with it? Or what i could try next?
I feel like i am missing out something.

Thank you for your help in advance,

Stephan

Hello,

if you have Turris OS 4.0.5, just use in CLI this command switch-branch hbk and you will have OpenWrt 19.07.xx. But as described in our documentation HBK is for experienced users.

Turris OS 4.0.5 which is based on top of OpenWrt 18.06 is still supported and the EoL is, for now, scheduled to the next month and by the time and even sooner it will be in the stable branch.

You haven’t told us, why you would like to try OpenWrt 19.07.02 on your router. You shouldn’t use sysupgrade or flashing router via LuCI. That’s not supported and will be removed. And if anything goes wrong, it is not supported. It might require the serial console or sending to us.

1 Like

Thank you for your fast reply.
I need to test wpa3 for a project.
i tried to switch branch but i get the following error:

root@turris:~# switch-branch hbk

  • uci set ‘updater.turris=turris’
  • ‘[’ n ‘=’ y ]
  • uci set ‘updater.turris.mode=branch’
  • uci set ‘updater.turris.branch=hbk’
  • uci commit updater.turris
  • ‘[’ n ‘=’ y ]
  • sed -i 's#https
  • ‘[’ n ‘=’ y ]
  • updater_args=
  • config_get_bool updater_approvals autorun approvals 0
  • local _tmp
  • config_get _tmp autorun approvals 0
  • eval export -n – ‘_tmp=${CONFIG_autorun_approvals:-${4}}’
  • export -n – ‘_tmp=0’
  • _tmp=0
  • export -n ‘updater_approvals=0’
  • ‘[’ 0 ‘=’ 1 ]
  • updater_args=–batch
  • pkgupdate --reinstall-all --batch
    INFO:Target Turris OS: 5.0.0
    line not found
    line not found
    line not found
    line not found
    line not found
    ERROR:
    inconsistent: Requested package updater-supervisor that is not available.
  • echo ‘Updater execution exited with error. Please see previous output to know what went wrong.’
    Updater execution exited with error. Please see previous output to know what wen t wrong.
  • opkg update

Signature check passed.
Collected errors:

  • echo ‘OPKG update failed. Please see previous output to know what went wrong.’
    OPKG update failed. Please see previous output to know what went wrong.
  • set +x

("-''-/").___..--''"-._
6_ 6 ) -. ( ).-.__.)
(Y.)’ ._ ) ._ . ``-…-’
…`–’…-/ /–’.’
((((.-’’ ((((.’ (((.-’
You are now in branch containing software build every night. It often contains bugs and sometimes requires manual intervention!
It is based on latest stable OpenWRT branch with Turris OS changes.
Turris team provides no guarantees and no support for this branch. You can get some help on forum .
If you encounter some bugs than please debug cause and report it to developers trough gitlab,
You shouldn’t be in this branch unless you are advanced user!
To return to stable branch run this command: switch-branch hbs

Got any tipp whats the problem? I installed the updater-supervisor on the LuCi GUI.

Thanks!

the installed theme (rosy) is marked as broken in OpenWrt 19.07 aka TurrisOS 5, therefore please remove this theme before branch update, e.g.

opkg remove luci-theme-rosy

… after that repeat the switch-branch step.

Edit: just noticed the other error regarding ‘updater-supervisor’ … that looks odd.

1 Like

That does not help in this case. The update didn’t proceed successfully. There is a missing package, which should be solved after midnight and it will remove luci_theme_rosy.

2 Likes

Thats right. Today it works!
Thank you.
But i see that wpa3 is still no available option… too bad.
But thank you for all your help guys!

Alternately with mesh support, wpad-mesh-openssl or wpad-mesh-wolfssl

1 Like