Updater failed now stuck on forus & errors on updater.sh and pkgupdate

solved
release

#1

Hi,

In foris I saw a number of downloaded changes that would be force installed on 5th December. So I decided to install them right away and clicked on install. After 2-3 Minutes I got a error page in foris and afterwards foris was only throwing more errors.

Logging in through ssh revelaed that pkgupdate --batch --reexec was runnig (although “–reexce” is undocumented.

As it never finished I rebooted the device. First thing I noticed it took very long to come back up and I think some services were not started so it got stuck somwhere while booting.

But the worst thing is in Foris (which is now working again) the updater tab shows a this icon which indicates it’s working (which it is clearly not). When I try to run updater.sh I got the following error:
INFO:Detected existing journal. Trying to recover it.
line not found
line not found
line not found
line not found
DIE:
[string “backend”]:1173: [string “backend”]:1164: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable

The same happens when I try to run “pkgupdate”.

How to solve this?


#2

UPDATE: After removing the lock file pkgupdate recovered from the profile and started working for a very long time and got stuck somehwere at hd-idle.postint.

After cancelling postinst process and running pkgupdate a 3rd time where it finally made a snapshot, removed leftover files etc. it seems system is back up and running again.

Also the update running icon in foris is gone. But for next I wished that the update goes much smoother all this rebooting, tweaking and fiddline around is not what I call an easy automatic update.


#3

possible duplicate of Pkgupdate fails for latest update


#4

No, that’s different. See, he’s 2nd post.

DIE:
[string “backend”]:1173: [string “backend”]:1164: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable

This means that Updater is in progress. I think he was too hurry. We don’t know, which version of Turris OS he was using and to which version he updated.


#5

I was regularly applying the updates (or at least foris was set to do so). So I think my version wasn’t very old. Is it normal that an update takes more then 10 minutes?


#6

We have the same issue for months now. Actually it never worked correctly since we have our Turris device.
I also tried to stop it manually but it gets stuck again everytime I try… Can’t remember right now what was the exact error message.

When I tried again today, the error changed to the following:

root@nobody:~# pkgupdate
INFO:Detected existing journal. Trying to recover it.
INFO:Running post-install and post-rm scripts
Output from openssh-server.postinst:
rm: can't remove '/etc/uci-defaults/sshd': No such file or directory
Output from turris-version.postinst:
/usr/lib/opkg/info//turris-version.postinst: /usr/lib/opkg/info/turris-version.postinst-pkg: line 9: lxc-config: not found
/usr/lib/opkg/info//turris-version.postinst: /usr/lib/opkg/info/turris-version.postinst-pkg: line 9: lxc-ls: not found

Then it is stuck again and I can only wait (and CTRL+C after 60 minutes)