Updater failed: inconsistent: Requested package libustream-cyassl that is not available

Hello everybody,

Had no problems for a long time, but today got this mail:

Error notifications

Updater failed:
Inconsistent: Requested package libustream-cyassl that is not available.

The Omnia ran now a few weeks without problems (except Sunday reboots).
No change was made.
What is the problem?
And how can I fix it? Is a restart sufficient?

Thanks and best regards


Could you pm me files /etc/updater/user.lua and /etc/updater/auto.lua?

I get the same error message for some weeks now only with a different package:

But the lftp package is there when I search via luci > software. Running opkg update > updater.sh yields the same error message. How do I resolve this?

This is probably because you have probably some other repository added to distfeeds configuration. This files is not read by updater. To make it consistent you can run switch-branch deploy (or any other branch you are in currently). But of course this doesn’t solve you problem. I checked and we are no longer compiling this package. I am not sure why (probably because it’s currently broken). So either replace it with some other software or use older version (https://www.turris.cz/doc/en/howto/downgrade_packages). But second one is highly unrecommended.

1 Like

That’s not nice. Indeed, it disappeared from my installed packages, lftp: not found. I have been an avid lftp user and was glad that it was running on the Turris. I need to know, will you be picking it up again?

It still appears when searching for it but won’t install:

Right now lftp build is failing. Related issue is https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/96, you can check progress there.

1 Like

Heh, alright. Fair enough. Thanks for putting up the bug report. It’s not Turris dev’s fault. lftp was like my daily go-to piece of software for all that is sftp in my life. :pensive: Will have to go with lxc for now then.

Hi, @cynerd @paja

I got the same error with different package on 3.9.6.

I’ve installed the package using opkg install from downloaded file (softethervpn), and added it to localrepo. Later I’ve removed it - opkg remove and localrepo rm and now updater gives me

inconsistent: Requested package softethervpn that is not available.

and I can see Install("softethervpn") in /etc/updater/conf.d/opkg-auto.lua. Can I remove it manually despite the warning there or how could I fix it before it would be fixed? :slight_smile:

EDIT: Does it mean that the updater now “works” (or try to) with opkg and localrepo is not needed and that’s why it’s messed? If so it would be very nice to write it to documentation

EDIT2: cosmetics - in notification mail the updater shows unknown error

Yes you can. It’s there just so you won’t edit it in some more let’s say progressive way. Then you would confuse opkg wrapper that maintains this file.

You shouldn’t have to remove it from localrepo. It’s cleaned automatically from it when package is not installed.

I tried it with some dummy package and for me it seems to work. So there must be something that in your case is different from normal. Only known problem at this moment with opkg-wrapper is this: Sign in · GitLab
Are you able to recall what was exactly sequence of actions you used to encounter this issue?

Updater was always working with opkg (with known limits). And localrepo is still needed (it wasn’t just some temporally thing). It was always handled by wrapper script that is installed as opkg executable. This topic talks about problems with localrepo (when it was released it contained bug where new repositories were not correctly registered). May I suggest you in future to create new topic instead of resurrecting almost half a year old topic. You can always use links to link to some older topics.

Known. Already fixed: Sign in · GitLab
In future please report apparent bugs directly to gitlab. We might miss such reports here on forum.
But thanks either way.

Thanks again,

I did tried it now with some luci-theme ipk and it works ok as you also found out and I haven’t did anything differently.

Except maybe when playing with softethervpn I found out that it runs by default on port 443 and after restarting turris lighttpd wasn’t working (so no luci, forris etc - probably due to it) so I’ve changed softether server port and restarted turris again and both vpn and http servers worked after that. I’ve uninstalled it (and removed from localrepo) later.

Could it be related to non working lighttpd? Or could also something else not work and I just noticed lighttpd when softethervpn occupied 443? But I’ve uninstalled it when lighttpd was online again. Now came to my mind that when removing it from localrepo there was some error message (but I’m not sure about that 100% and I don’t remember the text - and there was no error message now when I’ve tried to reproduce it with luci-theme package)

OK, if it’s better for you (and the team). I just don’t like to create new topic if I found similar because it also motivates others to “ask first, search later” but it make sense in bugs category


just little idea for updater improvement - would it be possible if the updater checked installed packages from opkg and localrepo and self-repaired /etc/updater/conf.d/opkg-auto.lua?

I know it’s easy for me to suggest but you can easy think if it’s possible and how hard it could be.

It’s not solving root cause (which is unknown ATM) but could it could help avoid similar situations. Or maybe not to do such check in updater but in localrepo check or something like that so it can be repaired if it happens.

Well problem I see is that you have to cross-reference three places and decide which one is deciding combinations. One place is what is installed in system, another what is specified in updater’s configuration and later one what is really in localrepo. I had no time to think about it hard but in general any decision would have to be done with idea that system is in consistent state and that way you can decide what can be removed. You see there is no way I can say that given package should be in localrepo other then that it’s not installed in system but is in opkg-auto.lua (and even that is kind of questionable). Because of that there is no way the updater would do it automatically on its own. There has to be user oversee to confirm changes. localrepo might be better place but I wouldn’t do it as that script has nothing to do with opkg-wrapper (that is a component responsible for opkg-auto.lua) also there is no facility in that script to work with lua script. More appropriate I would see some separate fixup script. But in reality I have no time to write it atm. If you have then you can contact me and ask me any technical question about updater and localrepo. I might do it but probably not in near future. Also it might be more beneficial use of my time to just found root cause of that problem instead.