Updater error message

For the past 4 days I’ve been getting the following error email from the router.

strong text##### Error notifications #####**
Updater failed:
unreachable: /tmp/crl.pem: No such file or directory
strong text

Is there a part missing to the script or do I need to do something?

Thanks in advance

same here, any feedback yet?

Guys try to use search first please, this topic is here many times… This one worked for me.

mea culpa
I was too quick on the trigger :slight_smile:

I have tried this, I get a new crl.pem file downloaded, reboot the router and I still get the updater failed error.

I have tried to run the update.sh manually and get error messages.

“Script revision-specific not found”
“Script serial-specific not found”
“Lock on //var/lock/opkg.lock released by garbage collector”

The return code is 0

The crl.pem file size is 2KB (in MS Windows)

Any suggestions gratefully received.

PS: I have just noticed in the System Log the entries;

2017-04-02T03:44:23+10:00 emerg kresd[2086]: curl: (6) Couldn’t resolve host 'api.turris.cz
2017-04-02T03:44:24+10:00 crit updater[2375]: src/pkgupdate/main.c:208 (main):
unreachable: /tmp/crl.pem: No such file or directory

Is the problem that the Turris server is not accessible?


I just saw the error pop in FOSI for the first time ever. Maybe there no issue. maybe I wait 12hrs and the error does pop back up and the connection was down before when it tried to update. But that said I don’t fully under stand your reply. Ok delete a file. Get that. easy. But download crl.pem with output? please explain that a bit better to me.

I saw this error. I use putty and did SSH terminal. I tried to manually launch updater.sh
That did run either. My first time ever running it from the prompt.

I got:
root@turris:~# /usr/bin/updater.sh
WARN:Script revision-specific not found, but ignoring its absence as requested
WARN:Script serial-specific not found, but ignoring its absence as requested
WARN:Lock on //var/lock/opkg.lock released by garbage collector

Now it might just be me doing something stupid. In Ubuntu I must do “sudo -s” for the apt-get commands to function. Do we have to elevate the user level to run updater.sh?? If so whats the command for that? it isn’t sudo.