Update z 3.9.6 na 3.10 turris 1.0


#1

Ahoj,
mám probém

Turris 1.0

|Verze Turris OS |3.9.6|
|Verze jádra |4.4.119-df8c454b3cdf471ca0ef3e4df07c2cb7-0|
|Odesílání dat z uCollectu |Online (stav aktualizován před 112 sekundami)|
|Odesílání firewallových záznamů |Online (stav aktualizován před 403 sekundami)|

po pokusu o update chyba, nakonec jsem zkusil rucni spusteni

updater.sh

a vysledek

root@turris:~# updater.sh
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package daemon-watchdog that is missing, ignoring as requested.
WARN:Requested package https-cert that is missing, ignoring as requested.
INFO:Queue install of libgcc/turris/4.8-linaro-7
INFO:Queue install of libc/turris/0.9.33.2-7
INFO:Queue install of updater-ng-migration-helper/turris/60.2.4-2
INFO:Queue install of libopenssl/turris/1.0.2o-1
INFO:Queue install of openssl-util/turris/1.0.2o-1
INFO:Queue install of ca-certificates/turris/20170717
INFO:Queue install of libcurl/turris/7.60.0-1
INFO:Queue install of updater-ng/turris/60.2.4-2
Press return to continue, CTRL+C to abort

INFO:Executing preupdate hooks…
INFO:Subprogram output: /etc/updater/hook_preupdate/05_schnapps.sh:
Snapshot number 53 created

INFO:End of subprogram output
INFO:Unpacking download packages
INFO:Checking for file collisions between packages
line not found
line not found
line not found
line not found
line not found
line not found
DIE:
[string “transaction”]:317: [string “transaction”]:146: Collisions:
• /usr/bin/updater-wipe.sh: updater-ng (existing-file), updater-ng-migration-helper (new-file)
Aborted
Working on message: 1528403910-11171
Working on message: 1528404031-11676
Working on message: 1528404172-12126
Working on message: 1528404336-12740
Working on message: 1528404570-13329
Working on message: 1528404867-14026

asi delam neco blbe, ale nejak neivm co

diky za rady a porady
David


#2

chybu v podstatě vynutí už jen opkg update, nepopmohl ani návrat o X verzí pomocí schnapps, stále stejná chyba. Mno vidím to na factory reset z čeho nemám teda velkou radost.


#3

root@turris:~# updater.sh
updater.sh is obsoleted. Please use pkgupdate directly instead.
root@turris:~# updater.sh
updater.sh is obsoleted. Please use pkgupdate directly instead.
root@turris:~# WARN:Couldn’t read the status file: [string “backend”]:1172: [string “backend”]:1163: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-cs that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-en that is missing, ignoring as requested.
INFO:Queue install of updater-ng-migration-helper/turris/60.2.4-2
INFO:Queue install of libcurl/turris/7.60.0-1
INFO:Queue install of updater-ng/turris/60.2.4-2
INFO:Executing preupdate hooks…
INFO:Unpacking download packages
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-cs that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-en that is missing, ignoring as requested.
line not found
line not found
line not found
ERROR:
[string “backend”]:1172: [string “backend”]:1163: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable
INFO:Checking for file collisions between packages
line not found
line not found
line not found
line not found
line not found
line not found
DIE:
[string “transaction”]:317: [string “transaction”]:146: Collisions:
• /usr/bin/updater-wipe.sh: updater-ng-migration-helper (existing-file), updater-ng (new-file)

mam v podstate to stejny … na update se ma pouzit normalne teda opkg update nebo jak?


#4

stejnej problem z EN fora Firmware update failed on brand new TurrisOmnia V3.8.3


#5

Dobrý den,
velmi se omlouváme za způsobené problémy při aktualizaci z 3.9.x.

Opravu máme připravenou a bude se nacházet ve verzi Turris OS 3.10.2. než dojde k vydání, tak máme pro Vás workaround s tím, že je nutné se přihlásit na SSH a zadat následující příkazy:

opkg-trans -r foris
pkgupdate

Budeme se snažit vydat 3.10.2., co nejdříve to bude možné.


#6

Super diky!

Edit: no bohuzel nepomohlo …

output:

root@turris:~# opkg-trans -r foris
INFO:Unpacking download packages
WARN:Package foris is not installed. Can’t remove
INFO:Checking for file collisions between packages
INFO:Running pre-install scripts and merging packages to root file system
INFO:Running post-install and post-rm scripts
INFO:Removing packages and leftover files
INFO:Cleaning up control files
root@turris:~# pkgupdate
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-cs that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-en that is missing, ignoring as requested.
INFO:Queue install of libcurl/turris/7.60.0-1
INFO:Queue install of updater-ng/turris/60.2.4-2
Press return to continue, CTRL+C to abort

INFO:Executing preupdate hooks…
INFO:Unpacking download packages
INFO:Checking for file collisions between packages
line not found
line not found
line not found
line not found
line not found
line not found
DIE:
[string “transaction”]:317: [string “transaction”]:146: Collisions:
• /usr/bin/updater-wipe.sh: updater-ng-migration-helper (existing-file), updater-ng (new-file)
Aborted
root@turris:~#


#7

Ahoj,
tak jo, zabralo to, díky za rychlé řešení

D.


#8

ahoj, já jsem ručně odinstaloval updater-ng a nainstaloval updater-ng-migration-helper a potom znovu nainstaloval updater-ng… ale ještě předtím jsem se trápil s několika balíky které zmizely z repa… jako balíček NUT pro upsku… pak se to celé rozjelo… ale udělalo to po sobě celkem bordel… vytvořilo to hromadu configů s příponou -opkg které byli v konfliktu s původními… a netuším jestli to nemělo třeba dopadnout nějak jinak… Jestli nebyl přichystán nějaký merge pro ty configy… do logu pak přistálo několik chyb z aplikací které jsem nikdy nepoužil…


#9

Dobrý den,
pokud byste ještě dnes narazil na Váš zmíněný problém, kdy se nedařilo aktualizovat na nejnovější verzi Turris OS kvůli následující kolizi:

[string “transaction”]:317: [string “transaction”]:146: Collisions:
• /usr/bin/updater-wipe.sh: updater-ng-migration-helper (existing-file), updater-ng (new-file)

Tak je nutné odinstalovat balíček updater-ng-migration-helper, který jste pravděpodobně nainstaloval z důvodu vyřešení chyby, která se objevila ve verzi Turris OS 3.10.1. Po odinstalování balíčku spusťte Updater v příkazové řádce, případně jej můžete vyvolat také ve Forisu v záložce Updater kliknutím na tlačítko Save changes a není nutné provádět jakoukoliv změnu.

Dejte mi, prosím, vědět, zda Vám to pomohlo.


#10

Zapomel sem zareagovat. Dekuji pomohlo


#11