Update to TOS 5.1.7 breaks Omnia


it seems that for me the automatic update to 5.1.7 basically breaks everything running on my Turris Omnia (2020 model). Up until 5.1.6 everything was working fine.

The update finishes successfully with no errors, but after a reboot there is no DHCP, DNS, WAN connection, foris, luci, …
Literally nothing works.

Same thing happens when I run pkgupdate manually.

I spent the whole night trying to figure out what the issue is, but at this point I have to give up. Any help would be appreciated.


Update Log (5.1.6 -> 5.1.7): https://0bin.net/paste/D7ULnoIM#YUfRMB8gLholkSL5nJhm9uPw6NBauTSL7XriPRwLCWO

Syslog after reboot: https://0bin.net/paste/LQQeg0DP#TsKV71vCETxpJrVY723CReHgMQ2h8HKGxPO6lglowGe

Installed packages (before update, working state on 5.1.6): https://0bin.net/paste/LwgfdRxF#6rdcHY-fBESTUUoV0kRXCUXzyQCOvcpp2bQNjdrhOI2

dmesg (before update): https://0bin.net/paste/MPs6LXkN#8jee3Rg9YCUQ4-9/yuhW9yjzgcd5tLocLN4EqNyWR/2

You may get better syslogs after you fix your syntax:

Jan 22 06:14:03 turris syslog-ng[4236]: confgen: Generator program returned with non-zero exit code; reference='/etc/syslog-ng.conf:29:2', context='source', block='network_localhost', exec='/usr/share/syslog-ng/include/scl/network_localhost/detect.sh', rc='1'
Jan 22 06:14:03 turris syslog-ng[4236]: Error reloading configuration; reason='Syntax error parsing configuration file'

The logs may be more informative after this gets fixed. I didn’t see any messages about dnsmasq, but I can’t tell if that’s because syslog is barfing or if dnsmasq isn’t running.

It looks like you have some issues with mosquitto too.

Hello @huibuh,

Can you please tell us a little more details about your configuration and if you are running a different kernel configuration than we and such. Any details can help to take a look at your issue.

In the meantime, as @jklass pointed out, you should take a look at syslog-ng configuration file and fixed it. It looks like a custom configuration of that file.

I don’t like these rows in your system log:

  • Jan 22 05:14:03 turris procd: Got unexpected signal 1 and haveged, sshd, mosquitto crashed with the same issue.
    And if procd does not run, then things goes bad…
  • Multiple tries to load ACL for ubusd

You should take a look at mosquitto as well.

Funny enough, while I was out today the upgrade to 5.1.7 succeeded and is now working. I still have no clue how, since I reverted to 5.1.6 and left it at that this morning.

I was running stock kernel. I also didn’t touch any configurations except for setting up Wifi + Guest Wifi and OpenVPN + vpn-policy-routing. Certainly didn’t mess with syslog, dnsmasq, mosquitto,…

I would leave it alone for now and see if the problem comes back with the 5.1.8 upgrade.

Thanks for the quick responses, much appreciated.