Update 3.5 out now

Dear users,
a long time anticipated update will be out in minutes!

What will be inside?


• Wi-fi issues fixes: ath10k drivers are back so there shouldn’t be wi-fi problems anymore!
• To all those, who had problems with not starting web interface, it is fixed too.
• You shouldn’t receive notification emails about not sending data while your router is online, there was a problem that is now fixed. If your DNS works, there won’t be any problem.
• There were problems with PPPoE athentication via CHAPS, it is fixed now, PPPoE should work smoothly.
• Error while loading backed up conficuration is fixed, there shouldn’t be any falls.
• We fixed many errors in opkg so you won’t meet “segemntation fault” too often.
• ebtables: falls fixed!


• Knot-resolver now supports forwarding to more than one DNS server
• new package inside: fstrim
• OpenSSH is updated to the latest version


This topic is now a banner. It will appear at the top of every page until it is dismissed by the user.

I’m not sure about that (there is nothing about ath9k), but Turris 1 wifi is working now as before 3.3 (updated 5 minutes ago).

“New: the Wifi driver is back to what it was before”?

for me the update failed and the box was hung up in a bootloop
atm the update.sh fails with

[string "transaction"]:310: [string "transaction"]:143: Collisions:
• /lib/firmware/ath10k/QCA988X/hw2.0/board.bin: ath10k-firmware-qca988x (new), ath10k-firmware-qca988x-ct (existing)
• /lib/modules/4.4.39-80079e1c1e5f9ca7ad734044462a761a-3/ath10k_pci.ko: kmod-ath10k (new), kmod-ath10k-ct (existing)
• /lib/modules/4.4.39-80079e1c1e5f9ca7ad734044462a761a-3/ath10k_core.ko: kmod-ath10k (new), kmod-ath10k-ct (existing)

removing all ath10k related stuff (incl. the firmware packages) fixed it for me

1 Like

The firmware used for the 5GHz card is now the “regular” firmware and no longer the -ct variant. The latter had been used for 3.3 and 3.4.

How did you get out of the bootloop? I fear one of my Omnia (I have 2) may have ended up the same (but I can’t check as I rebooted it remotely).

Have you tried installing ath10k-firmware-qca988x-ct by hand previously?

thx for the update!

-ct firmware (in this form) probably should not have made it into stable/deploy.
wifi was utterly unusable.

any reason why kmod-sched-cake did not ?

the WatchDogScript rebooted my box, so I had about 2 minutes to get it fixed and then had to wair for it to reboot (it actually booted up just fine)
Somehow the uodate was quite messed up, kernel 4.4.39 was installed but missing all its modules and as a result ppp was not working which triggered the reboot after some moments trying to reconnect.

I cannot say that for sure, but it might be, it is kind of sad that opkg does not have a real resolver :stuck_out_tongue:

Note that the issue where the LAN ports in some cases do not come up properly on power up or reboot is still there. So the workaround from Swich ports offline if plugged during boot is still required until update 3.6. Per the Omnia developers the cause is known and a permanent fix is in testing for 3.6, for those who are familiar with how to test on the Omnia they are looking for testers of the fix on that thread.

As you can see in that thread which you mention it doesn’t make it into 3.5, because it isn’t tested properly.

If you can’t wait, you can test it in today/tomorrow nightly branch otherwise it will be in 3.6.

Pepe yes understood it didn’t make it since it’s not tested, I plan to help with that part :grin:

I’ve tried several times, update.sh fails every time. Hangs at this:

Output from foris.postinst:
+ [ -n  ]
+ [ -f /www2/forris.pyc ]
+ /etc/init.d/lighttpd enable
+ /etc/init.d/lighttpd restart
Output from knot-resolver.postinst:
+ [ -z  ]
+ /etc/init.d/dnsmasq restart
+ sleep 2
+ /etc/init.d/resolver restart

Never get a prompt back. If I force reboot the Omnia everything is pretty much a mess, . Fortunately I can schanpps rollback to a good config.

For me, 3.5 is a dud.

I have this problem with update.sh

  • IFS=
  • mkdir -p /tmp/update/packages
  • opkg list-installed
  • sed -e s/^/^/g
    Segmentation fault
  • [ ! -s /tmp/update/list-installed ]
  • my_logger -p daemon.error
  • logger+ echo Failed to get list of installed packages
    -t updater -p daemon.error
  • false
  • rm -rf /tmp/update /tmp/update-state/pid /tmp/update-state/lock /usr/share/updater/packages /usr/share/updater/plan
  • exit 1

Any idea how I can fix it to update 3.5? Thank you

You need to wait quite a while. It took about 2 minutes on both my Omnias.

I waited 30 minutes at the longest, figured that was plenty of time.

I gave it a few more tries, lots and lots of issues. I might try a full wipe and update, but so far, not very happy with 3.5. 3.4 was far better for me.

I still dont have recieve update notification. Why is my TO in delay?