Uninstalling Nextcloud

Error msg when removing Nextcloud via either luci or cli :
WARNING: You probably just removed a package that was installed as part of a user list or the basic system. This package will return durring the next updater run. We suggest you disable the user list instead.

How does one disable the user list?

(Nextcloud checkbox is unchecked in the reforis pkg manager. Turris Omnia, TOS 6.0.1)

Maybe take a look at /etc/updater/conf.d/opkg-auto.lua if it is marked for installation there.

I have this error:

Upozornění od Vašeho routeru turris

Oznámení o chybách

Běh updateru selhal:
compilation: [string “file:////etc/updater/conf.d/nextcloud.lua”]:2: ‘=’ expected near ‘’"

What is the content of your’s file /etc/updater/conf.d/nextcloud.lua?

Install(“nextcloud-install”) pkgupdate

Thanks for your suggestion, though nothing related to nextcloud there. But you pointed me in the right direction, so now I’m deleting /etc/updater/conf.d/nextcloud.lua.

I tried to uninstall Nextclod from my Turris Omnia, but it looks difficult.

  1. It is switched OFF in the Reforris interface, but it is installed despite it.
  2. No field /etc/updater/conf.d/nextcloud.lua is available in my Omnia.
  3. I tried removing Nextcloud packages via file /etc/updater/conf.d/user.lua and run updater, but it doesn’t work.
    Here is the content of my file user.lua:
Uninstall "reforis-nextcloud-plugin" "foris-controller-nextcloud-module" "nextcloud-install" "nextcloud"

After update via Reforris (script updater.sh wasn’t find) the log contains:

runtime: [string \"file:////etc/updater/conf.d/user.lua\"]:7: attempt to call a nil value"

My Omnia runs on reForis 1.3, Turris OS 6.0.

Can you please advise me how to uninstall Nextcloud?

Sorry, I really don’t have an answer. Here’s hoping that someone else here does.

I unchecked Nextcloud in reForis and that didn’t seem to do anything.

Tried a few things that didn’t work and then I ended up deleting:


And uninstalling with the below command:

opkg remove --force-removal-of-dependent-packages nextcloud nextcloud-install turris-webapps-nextcloud

A couple of hours later I got an updater notification from the router asking for approval to uninstall a bunch of packages (mariadb, php, etc).

This seems to have worked ok.

1 Like