Unable to update apps on Google Play Store

Hi everybody!

I have very strange problem. It is impossible to download or update apps on Google Play Store. I have tried to restart my Omnia (running on 3.11.6), I have tried to disable adblock, but nothing helped. Searching for apps works fine.

This problem occures on all devices, on all wifi networks (even on guest wifi, where adblock is disabled permanently). This problem is even on AndroidTV which is connected to LAN.

All devices update apps normally when connected to different wifi networks…

Any ideas what to do?


PS: Some days ago, there were youtube playback problems (it was necessary to refresh site before each video - on windows and android too). After this problem was gone by itself, problem with Play Store occured…

Had a similar problem with a S7 yesterday.
Problem got resolved after answering a call…
I wouldn’t bother at all if @michalko58 didn’t open this thread.
But in the end this could also be a temporary problem with playstore?

This problem persists at least for 4 days on 3 devices (one TV and two cell phones) with 2 different google accounts. Both cell phones are able to update their apps on different wifi networks and via cellular data.

But when on wifi/lan from my Omnia, there is only “waiting for download” message and nothing happens. Even when was trying to install new apps.

What did you mean by “answering call”?

I can update with google play. Perhaps it’s not the omnia but your isp?

ISP is ok, I have tried it on another place with the same ISP - Orange SK

It is very strange, because nothing was changed in settings, etc.

I confirm Google Play has been down for 2 days and it’s not Turris or ISP! This is a bug on Google, please contact Google Support.

1 Like

This is not my situation. I just have updated one app via cellular data. I am able to download/update my apps everywhere except my home wifi on my Omnia.

So the problem is identified. The problem is with DNS.

I’m at work and we don’t use Turris or AdBlock here, we only use DNS over TLS. When I use another DNS, everything works. Here I can not further test (I’m at work), DNS will test when I am at home.

Try to set your Omnia to provide clients with DNS or so, and you will see if it resolves. (how-to: go to and on the bottom, under DHCP Server > Advanced Settings tab > DHCP-Options, enter

for example. Then restart your phone/tablet/PC/whatever

Ok, I will try it, at home, but it is strange, because I am using ISP´s DNS. The same DNS is used on network where everything is working…

So I’m home and testing on Turris + active AdBlock, also Google Play doesn’t work. I got to AdBlock, completely disabled Adblock, restarted Omnia and Android, and it started working.

I have found sources that block it (marked in red):

Uncheck the marked resources, restart Omnia and Android and try. It helped me. It is important to restart everything after changing to clear the DNS cache.

I see the problem in the source https://easylist-downloads.adblockplus.org/easylist.txt , where the domain from Google Play has been added and therefore Google Play is no longer working.


Thank you!!! This helped. From mentioned above, I have had checked only reg_ru . Unchecking solved my problem.

But strange thing is, that suspended adblock didn´t helped. It usually helps…

I’ve carefully analyzed the source and found the domains Google Play needs:


It might be enough to Whitelist these domains - but it’s not 100% - there may be another domain in the feed that Google Play will need and the search will start from scratch.


Well, for now, I leave that unchecked. It is strange that nobody else had these problems.

I confirm the 2 domains in whitelist are enough to fix the issue for me

After fresh TOS 4 installation and Adblock setting I can confirm too, that it is enough to whitelist:


great! i was looking for that one! :slight_smile:

Sorry for digging up an old thread but since a few days, I have the same issue that appeared without any change from me. I believe it may be related to an update but I can’t find out what and why.
adblock was installed but not started. I configured it properly and even try to uninstall it. not to avail…
Any idea on how to diagnose this ? Symptoms on 3 different androids apparel that can update when not on the Wifi…

What DNS are you using? Maybe change to some of Googles DNS may help ( or

Hi !
Thanks for the reply, I tried with Google and Quad9, also tried to change in the phone but not to avail…
Curious things, even though I disabled IPv6 on the router, on my mobile phone Wifi details, the first DNS listed is IPv6 (finishing by ::1). Little odd but not sure if may be linked to the issue