Unable to install Openwrt

First I want to apologize if I posted this in the wrong category. I wasn’t sure where to post this question.

I want to install openwrt.

I tried the instructions I found on the openwrt wiki: [OpenWrt Wiki] toh:turris_cz.nic:turris_cz.nic_omnia

Method 1 - USB ‘medkit’ image without serial

  1. Copy openwrt-mvebu-turris-omnia-sysupgrade.img.gz and omnia-medkit-openwrt-mvebu-turris-omnia-initramfs.tar.gz to the root of a USB flash drive formatted with FAT32 / ext2/3/4 / btrfs / XFS. Note that the medkit MUST be named omnia-medkit.tar.gz*
  2. Disconnect other USB devices from the Omnia and connect the flash drive to either USB port.
  3. Power on the Omnia and hold down the rear reset button until 4 LEDs are illuminated, then release.
  4. Wait approximately 2 minutes for the Turris Omnia to flash itself with the temporary image, during which LEDs will change multiple times.
  5. Connect a computer to a LAN port of the Turris Omnia with a DHCP client
  6. (if necessary) ssh-keygen -R
  7. ssh root@ ; mount /dev/sda1 /mnt ; sysupgrade /mnt/openwrt-mvebu-turris-omnia-sysupgrade.img.gz
  8. Wait another minute for the final OpenWrt image to be flashed. The Turris Omnia will reboot itself and you can remove the flash drive.

I got stuck on step 7.

root@turris:/mnt# sysupgrade ./openwrt-18.06.4-mvebu-cortexa9-turris-omnia-sysupgrade.img.gz
Firmware upgrade is not implemented for this platform.

So I tried resetting uboot by interfacing via serial.

Hit any key to stop autoboot: 0
=> env default -a
Resetting to default environment
=> saveenv
Saving Environment to SPI Flash…
SF: Detected S25FL164K with page size 256 Bytes, erase size 64 KiB, total 8 MiB
Erasing SPI flash…Writing to SPI flash…done

I have not tried the serial and TFTP method yet because I am not familiar with TFTP at all and I was hoping there was a solution for the problem with sysupgrade.

Does anyone know why I am having this problem?

It is more like the wrong forum. The OpenWrt forum is located here https://forum.openwrt.org

I considered asking in openwrt forums but when searching for my solution I found this post over there with a Similar problem.

The OP was instructed to ask over here before he found a solution on his own.

Edit: also it did seem at least a little reasonable because the version of sysupgrade I’m attempting to use is on turris, not openwrt.

I would ask anywhere I can find help at this point.

1 Like

The referral to the OpenWrt forum was not meant to rebut the reasonability, it is just that this forum caters to the TOS (with its own patches to install and maintain the TOS) but not to OpenWrt (sysupgrade).

sysupgrade is developed, maintained and utilized solely by OpenWrt and anything related to it would better be asked in the right place.

We are currently in the process when we would like to release a final version of Turris OS 4.0, but once we do it, there will be at least one more beta release as we want to fix a few issues, which was discovered by our beloved community and one of them is known - MariaDB.

Since Turris OS 4.0 is just a patchset for OpenWrt with extra feed (turris-os-packages). In the Turris OS packages, there are mostly our specific packages, which can not be sent to OpenWrt. You will find there some rare cases when we disagree due to different nature and want to take stuff in a different direction. As an example could be when we prefer user-friendliness and feature completeness oversize constraints. Others are in process to be upstreamed to OpenWrt/packages repository. We want to improve compatibility between Knot Resolver / Unbound and resolver-conf to rather implement something, which is compatible with upstream. Therefore, I shouldn’t forget to tell that we sent a lot of PRs to OpenWrt since January. Also, in Github pull requests to OpenWrt, we are helping our users, you can take a look here.

This means that what is in OpenWrt 18.06.04, that it is available in Turris OS 4.0. Same applies for OpenWrt 19.07 (Turris OS 5.0), master and so on. You can check file git-hash in repo.turris.cz in HBS/HBT/HBK/HBD/master folders. In that file, you can see which commits were used to build the release.

Before flashing OpenWrt, you may give it try with Turris OS 4.0 (with the stable release OpenWrt 18.06.04) and tell us, what you don’t like. Each feedback counts and we are looking forward to hearing that. Maybe in the future, you will realize that with OpenWrt, you are not supposed to use opkg upgrade and should look for new releases as from the time to time there are security vulnerabilities and you should be protected against them in time. In OpenWrt, you won’t be able to use all the internal storage, which is available as there is just 256 MB capacity for storage. It’s possible that they have changed since I tried it. In Turris OS releases, there is 8 GB storage available for you.

More details about the latest release of Turris OS 4.0, where you will find instructions how to give it try, if you want. If not, it’s your decision in the end. :wink:

Let me try to help you with the issue, which you seems to be having. You are correct that sysupgrade is disabled in Turris OS, this one indicates that you are still having Turris OS. Since you have a UART cable, you can try to repeat steps 1. - 3. and see what it does in the serial console. I am thinking that the router was not able to find medkit, so it couldn’t proceed the reflash. Did you download omnia-medkit-openwrt-18.06.4-mvebu-cortexa9-turris-omnia-initramfs.tar.gz and put it to the USB flash drive and then proceed 4 LEDs?

1 Like

It is more likely that sysupgrade from TOS3.x (legacy LEDE) to OpenWrt 18.06.x is not going to work (incompatible).

Pepe I appreciate all of the hard work Turris has put into the Turris Omnia. I do not mean to discredit the developers of Turris OS. I am happy that Turris has been submitting patches things “upstream”. That is always a good thing for the open source communities. There were a few reasons that I wanted to install openwrt.

One was that my router seemed to come with a lot of packages preinstalled that I would never use. I am a bit of a minimalist, I suppose. I believe that it is a better security practice to have fewer applications installed and as few processes running as possible. The more things you have installed on your device, the more likely one of them will have a security vulnerability.

I will follow your suggestion to try Turris OS 4 since it is closer to Openwrt.

I never did get openwrt to work but I was able to confirm via serial that flashing the omnia-medkit image was working as expected. However, I was flashing the medkit image of turris repository not the one from openwrt. That was my problem.