UI broken, then I got upgraded to 5.3.8, UI still broken

I tried to log in to my Omnia today to add a new static IP address. The HTTP UI failed to load (400 Bad Request). I logged in via ssh, ran pkgupdate, and now I appear to be on 5.3.8 where previously I was on 3.11.23. The UI is still failing to load, with the same error.


  • why wasn’t I automatically upgraded? According to 3.x migration - Turris Documentation this should have happened by now.
  • if I needed manual migration, why wasn’t I notified? What notification channels are there? (Pretty sure the Omnia knows my external email address.)

But the big one is:

  • how do I get the landing page back?

…actually, after the upgrade, I did get a notification (by email). So I know the notification channel works.

Looks like lighttpd is refusing to serve any static file requests from /www. But I’ve never seen a 400 with static files before.

1 Like

Please, do contact our customer support via: tech.support@turris.cz.

See the instructions on what kind of information to provide in order to get help really fast: