Twinkies stories in updating Turris 1.x on HBL

I run pkgupdate this morning, but same error appear since last week on OMNIA TOS6 HBL

omnia ~ # pkgupdate
INFO:Target Turris OS: 6.0
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
line not found
ERROR:
inconsistent: Package suricata-bin requires package libnss that is not available.

Please speed up TOS 6 as possible it would be great if we can have stable TOS 6 HBS. I migrated both Turris 1 and Omnia to HBL and those I devices I run normally.

2 Likes

I am still unable to proceed with pkgupdate due to missing knod-crypto-wg package and my situation is that I am stuck with unusable device that drop internet connection shortly after boot when it can ping and access internet for short time and then completely drop connection unable to ping even gateway but get address assigned. I don’t think this is off topic as it is IMHO related that due to missing dependency it could not update and it is quite frustrating situation that I don’t know now how to resolve. Likely I will have to plug old Turris 1.0 download medkit for omnia install factory and rollback to it and then install all the packages and configuration again. After doing this and fiddling with it many times I would love to enjoy some stability for while. And no I don’t need advices like to get back to stable branch. And yes I am experienced user to the extent I can compile packages. And no I will not report this bug as it will be marked as solved immediately. But still, I am stuck in this situation when i need working device because of work and also would like to put time on something else than fiddling with sometimes working sometimes broken connection.

1 Like

This is very short story, indeed.

1 Like

Fixed by delete of Install(“kmod-crypto-wq”) from /etc/updater/conf.d/opkg-auto.lua and running pkgupdate again.

It is possible to close this thread.

2 Likes