Turris Shield - no internet connection with the WLAN router

Hi together

I have an issue with my WLAN router, Netgear WNR 1000v2. Connected with the Turris Shield it cannot get an internet connection. I hoped it would be more or less plug and play, but it did not turned out this way.

Following is my network setup:
ISP router <–> Turris Shield <–> WLAN router

What points do I need to consider during the setup of the Shield and/or my WLAN router?

Hi, I’m using a AVM FritzBox but this shouldn’t consider. You have to choose a different network for your wan and you network. For example the isp-modem should have and the wan port . And on the “network” side you could youse the build in DHCP or something else. But the ip-range should different from the wan-port. For example I hope this helps.

Hello. I have a similar problem. I tried to install the Shield between the modem and the router.
optic modem — shield — router.
I have set the router to be at, so it doesn’t collide with the shield at Both shield and router have DHCP on WAN as well as LAN side. The router itself works okay after the change to But all stops working as soon as I put the shield in between. Neither nor is reachable, and the network is disconnected from the internet as well as the network is “unknown”.

I tried setting the shield to “computer” mode. It did not work. I tried to set it back (via factory reset). No success. I tried setting the router to “bridge”. Now the internet passed trough to a cable-connected computer, but all devices at WLAN were connected to the WLAN but not connected to the internet.

Please, do you know how to help with this?

Hi @Vojtech_Raim,

I don’t know exactly whether they recognized the problem correctly.
But if you want to operate the shield between ISP / modem / router -> shield -> private route, you have to use a subnet, as far as I know …

ISP / WAN -> (xx.xx.xx.xx / XX) <-> Shield <> Private Router <(LAN) 192.168.2.x or 192.168.0.x

Otherwise you would have to switch to NAT (network address translation) in your private router to use the area in the internal network …

The problem is probably due to the fact that you have 2 DHclients each, maybe you can deactivate the dhclient on the shield (via ssh -> root@

TODO: PrivateRouter -> Try Via Nat?
Shield -> all settings are correct? -> dns forwarding etc? Shield tests must all be green, except for ipv6 and dnssec.

Deactivate vtl Shield dhclient …

I hope my information is helpful