Turris Shield - Chybová hláška

Ahoj, mám Shield cca. 14 dní a neustále mi hází chybovou hlášku.

Updater failed:

inconsistent: Package mox-support is requested as critical. Cyclic dependency is not allowed for critical requests.

Jak z toho ven? Děkuji za radu… :wink:

Stejný dotaz v EN: Turris Shield Update?

Stejný dotaz, ale bez reakce.

Zdravím, @Molin.cz,

děkujeme Vám za nahlášení chyby updateru.

Našli jsme softwarovu chybu, která se tímto způsobem projevuje. Problém nastává, pokud se má Turris Shield aktualizovat z nějaké starší verze (ne jen té bezprostředně předchozí) rovnou na aktuální verzi Turris OS.

Oprava této chyby by měla být zahrnuta do příští opravné verze Turris OS. Až bude tato verze vydána jako stabilní, aktualizace operačního systému routeru by měla řádně proběhnout.


Chcete-li na aktuální verzi Turris OS přejít rovnou, můžete provézt re-flash nebo flash z internetu. Tím se zformátuje souborový systém na microSD kartě a nahradí se novou tovární verzí. Tyto zmíněné metody jsou popsány v angličtině v naší dokumentaci, kde je ke shlédnutí i instruktážní video. Tento návod je pro router Turris MOX. Pro Turris Shíeld platí obdobné s několika změnami, které jsou popsány na stránce dokumentace, která je věnovaná záchranným režimům Shieldu. Důležitý rozdíl spočívá v tom, že pro metodu re-flash je třeba stáhnout jiný soubor s medkitem (mox-medkit-contract-shield-latest.tar.gz.

Přijměte, prosím, naši omluvu za tuto nepříjemnost.

2 Likes