Turris OS 6.3.3 is released!

Dear Turris users,
we just released Turris OS 6.3.3 with minor fixes and security updates.

:rocket: New Features
• schnapps: add update-factory command to update the factory snapshot
• lxc: rely on TLS because GPG support was dropped upstream

:bug: Bug Fixes
• schnapps: better handling of invalid arguments
• Linux kernel: backport fix for random crashes on Turris Omnia
• foris-controller: unify reporting of lease timeout for IPv4 and IPv6
• turris-webapps-tvheadend: fix reverse proxy not correctly routing requests
• rainbow: keep LED intensity across reboots by default

:pushpin: Updates
• Linux kernel updated to 5.15.114 (MOX, Omnia) and 5.10.179 (Turris 1.x)

We appreciate any feedback regarding this release.


Omnia, upgrade from 6.3.2.
No issues observed.
Thank you for your work!

TO 2016, HBS branch, 2 GB, 2x WiFi, HaaS, RIPE Atlas, Sentinel, lxc, simple config, all seems OK.

Turris 1.1, update z verze 6.3.2 probehl bez problemu. Jen mne trochu vydesily zhasnute LEDky po restartu. Po stisku tlacitka na zadni strane routeru se rozsvitily.

After the update no lights come on.

Same here. Pressing the brightness button turns them on again. Haven’t tried how it behaves after reboot yet.

Bug here “JSON.parse: unexpected character at line 1 column 1 of the JSON data” when going to and “503 Service unavailable” when going to reforis/login.

This helped me:
root@turris:~# /etc/init.d/lighttpd restart

After update web interface is inaccessible to me. Restart did not help.

Its probably because I dont use my own self-signed certificate and https only.

Guys, I am not sure, what is happening inside the team right now, but for more than one week, your release is not tagged and in the Turris Build repository, there is script which will do the job for you.

You should have some check list what needs to be done after the release. There was such a thing on your GitLab. :wink:


Okay, something is definitely happening inside the Turris Team, as they are not capable of tagging the release after 2 weeks. :frowning:


Right now, I imagine cases when users are confused about whether Turris OS 6.3.3 is the latest stable version because if the release is not tagged, it does not appear in the documentation. Also, each minor and major release requires manually adding the headline to the documentation. I wonder what is happening because Turris OS 6.3.x releases are not even shown under Changelog page in the documentation. Someone is not doing what they need to do.


signed up solely for the purpose of making my first post, my last post. its been a good run y’all. I knew as soon as @Pepe posted his farewell that our once beloved Turris would essentially become a paperweight. good luck to all o7

This is rather a bleak outlook… I guess the beauty of the turris omnia is, that there is always the option of switching to upstream OpenWrt if need be. However I hope we are just dealing with a man-power issue due to being close to summer vacation season and not signs of team turris unraveling…

hmmm, bit worried here also that this whole project might be going south… or maybe everyone left is busy with the new model.
A model with only fiber i/o , so that’s nice for the corp market, but not for the home market, me think.

So , it is possible to run a OpenWrt OS on this? No driver issues? Since the hardware of the omnia is fine.

Well, current stable OpenWrt22 does not support mvebu due to a switch/VLAN issue (that is fixed in kernel 5.15), but eol’d OpenWrt21 and current snapshots do IIRC. Personally I still have hopes for team turris and I really like their value-adds (mainly the automatic updates from a source I happen to trust).


I have similar problem.

After update to Turris OS 6.3.3 web interface is inaccessible (ERR_CONNECTION_REFUSED).
Restart did not help.

Next step was rollback schnaps before update to 6.3.2 and it works well. But with next update again - the same problem - inaccessible web interface. … and next again rollback schnaps … a later again the same problem … and again same steps and same result :frowning:

Have you any advice?

Turris Omnia 2020

v6.3.2 → v6.3.3, so far no problems.

  • LXC, Wifi, DDNS, VLAN, everything works fine so far.

Isn’t it that Openwrt does support the Turris Omnia, but the switch/VLAN functionaliteit just does not work. I mean still better something than nothing. Back when i supported Turris Omnia 2016 release i indeed kept in my mind the possibility that the company might stop actively supporting it or even may go bankrupt, that we still always have a backup plan. How cool a company even might be, we must be realistic how certain decisions can have a impact…(yes…Sun Microsystems (Java, mysql, OpenOffice,) OwnCloud, MS…(Skype for Linux, Github - even though it still exists, i don’t trust them), Red Hat (CentOS, RHEL just recently) and i would not be so surprised that in the near future something will happen to Ubuntu as well as M$ is kind of heavily invested with WSL. So slowly i am un-Ubuntuing all my systems. Just waiting how the development of Rocky Linux will go with the whole RHEL behind paywall chaos.

Woah, it took 18 days to download, run the script inside Turris Build repository and push the tag for that repo. For another one, you need to do it manually. Usually, this job took several seconds. Weird, but they managed to do it. Finally. :slight_smile: Makes me wonder, if it is going to be faster for security vulnerabilities…

So, let’s get back to work and I am going to send pull requests to OpenWrt. :wink:


@Pepe there is already one security fix for bind in HBK so probabbly soon in 6.4.0. And please try to not be so sarcastic/ironic because they are going to ban you😋

But in my opinion is positive criticism.