Turris OS 6.3.3 is now in the Testing branch

Dear Turris users,
we just released Turris OS 6.3.3 to the testing branch with minor fixes and security updates.

:rocket: New Features
• schnapps: add update-factory command to update the factory snapshot
• lxc: rely on TLS because GPG support was dropped upstream

:bug: Bug Fixes
• schnapps: better handling of invalid arguments
• Linux kernel: backport fix for random crashes on Turris Omnia
• foris-controller: unify reporting of lease timeout for IPv4 and IPv6
• turris-webapps-tvheadend: fix reverse proxy not correctly routing requests
• rainbow: keep LED intensity across reboots by default

:pushpin: Updates
• Linux kernel updated to 5.15.110 (MOX, Omnia) and 5.10.179 (Turris 1.x)

We appreciate any feedback regarding this release.


Well, my MOX Classic didn’t boot up after this. Long LED blinking. Had to rollback.

MOX classic, HBK branch, .5 GB, 2x WiFi, simple config, all seems OK.
Tested nice new feature of schnapps - update-factory - OK.

Is ti possible that the update didn’t finished and your MOX was rebooted too soon? Aka if you try again, will it fail again?

Finally rainbow has been touched. Will the commands for brightness during day and night or other (indication of connection faults) work ?

No, I tried it again with the same result. The fact is that last week I had to replace SD card and used this procedure [MOX MicroSD - Turris Documentation](Turris Documentation MOX MicroSD). Now I’m on the hbt latest I wrote directly on the sdcard.

Omnia updated, no issue.

This can happen when you are not on the current bootloader. Try

opkg update
opkg install turris-nor-update

I don’t know if it’s the acceptable output:

Verifying /dev/mtd0 against secure-firmware.bin ...
1705eb30f3e7795d0805e97134515d91 - /dev/mtd0
e12a263c63bd9860cff844763e81e56b - secure-firmware.bin
Unlocking /dev/mtd0 ...
Erasing /dev/mtd0 ...

Writing from secure-firmware.bin to /dev/mtd0 ...
Verifying /dev/mtd1 against uboot ...
b029ef10edcb60a5c63b6b1b22d38c11 - /dev/mtd1
bd802eb0ec60fd89f983ac3cd4860fba - uboot
Cannot parse config file '/etc/fw_env.config': No such file or directory
Unlocking /dev/mtd1 ...
Erasing /dev/mtd1 ...

Writing from uboot to /dev/mtd1 ...
Verifying /dev/mtd3 against rescue ...
e9b30ada843663c579829652847c7bb8 - /dev/mtd3
39f02d9fb36b4258bac37924bcdf570c - rescue
Unlocking /dev/mtd3 ...
Erasing /dev/mtd3 ...

Writing from rescue to /dev/mtd3 ...
Can't find anything to flash to 'dtb' partition

Yes, that’s fine. You were indeed running an outdated bootloader. Failed means the installed version did not match the current version, so the partitions have been updated. That’s what you wanted.

OK, thx. I was confused by the order of the messages :slight_smile: But now it makes sense to me

We just released rc2 with a kernel update to 5.15.114 for Omnia and MOX.

@tommyq could you try to reproduce your mox issue with this release?

Hi, seems good. The bootloader update fixed it, so after this kernel update it booted normally.

Update ok for Mox with U-Boot 2021.10-rc3-00050-g7d3fea2c7f (Sep 07 2021 - 18:16:56 +0200). I updated from 6.3.2 skipping the first RC.

Jenom dotaz - mám Turris Omnia a nainstalovaný NetMetr i LibreSpeed.
V sekci “Přehled” se mi stále zobrazuje jenom výsledek posledního měření přes NetMetr.
Neuvažovali jste o tom dát do této sekce i poslední výsledek z LibreSpeed?

Netmetr odinstaluj - proč? Protože je plánované ho z balíčků odebrat

6.3.2->6.3.3 RC2 update ok (no new problems introduced), no unintended cable/wifi or internet downtime. Restart needed.

Turris Omnia 2017, 1 GB RAM, dead eMMC, system running from mSATA SSD, original wifi cards. Storage plugin enabled, LXC containers, tor relay, USB HDD shared over samba4 and minidlna, SQM, Hardwario gateway + MQTT IoT bridge, OpenVPN, PPtP VPN, morce.