Turris OS 6.2.4 is now released

Dear Turris users,
we have just released Turris OS 6.2.4 which mostly contains security fixes and a fix for running transmission and syncthing webapps out of the box without having to configure them from the command line.

:bug: Bug Fixes

  • Fixed running Syncthing and Transmission webapps out of the box

:pushpin: Updates

  • BIND updated to 9.18.11 (security update)
  • OpenSSL updated to 1.1.1t (security update)
  • Linux kernel updated to 5.15.94 on Omnia and MOX and to 5.10.168 on Turris 1.x

We appreciate any feedback regarding this release.


Omnia 2016 & mox classic, all well.

1 Like

Everything works perfectly. I am on Omnia 2020, mSATA SSD boot, WAN on SFP cage, WiFi 6 kit, LTE kit, PaKon, Netdata, Transmission, Syncthing, Nextcloud. A little beast.

EDIT: I forgot WireGuard.


Can i ask if you may use a TL-SM321B SFP Module? And if your WAN does reconnect without issues after a restart? Just wondering :slight_smile:

From the 4.x branch of Turris OS it appears to be compatible (Supported SFP modules [Turris wiki]).
For rebooting, there are no problems. For newer versions of Turris Omnia, the hardware recognizes whether the Ethernet cable or SFP is used and loads the corresponding DTB (Devicetree - Wikipedia)

Yes i know that, thats why i asked if you have that module, cause since version upgrade to 6.2.3 i have the issue that it only reconnect if it remove the wire…

I don’t use that form, so I can’t help you. Try looking at the Linux kernel changelog and see if anything has changed for your SFP module. I have some doubt about that, that is, I don’t think anything has changed, but it won’t hurt to take a look.

I know that i can look into the 1k commits, but asking first can’t hurt. :slight_smile:

Ctrl+f and search for TL-SM321B.
Look from the working kernel version to this one if there have been any changes. However, sometimes the SFP recognition failed on my module as well. Try manually linking the correct dtb in the /boot folder or wait for the module to cool down and try again.

The update was fine, but my router dropped it’s WAN connection sometime after downloading the update. I’m not sure if something happened with the download or some sort of pre-install action that caused it. It could also be something random.

LAN was fine, but I didn’t really check WLAN. I rebooted it before I checked any logs either, but those are sent to a different server. After I rebooted, I got my WAN connection back and proceeded with the upgrade with no other issues.

TO 2016, HBS branch, 2 GB, 2x WiFi, HaaS, RIPE Atlas, Sentinel, lxc, simple config, all seems OK.

Yes, that could be possible as there was a small tweak related to Knot Resolver, but the restart of the DNS resolver should be hardly noticeable.

restart of the DNS resolver should be hardly noticeable

I see. Perhaps it’s my complex custom.conf for Knot that caused my WAN connection to stay down, though I’m not sure why.

Omnia 2020. All fine.

Turris Omnia 2020. Turris OS v6.2.3 → Turris OS v6.2.4

Everything works fine.
Linux Container, Dynamic DNS, WiFi, Vlan.

omnia 2016 - all ok except SFP - same as described here Switching WAN to SFP - Software / SW help - Turris forum

Setting up a new Nextcloud is still not working. (Mox)

Sorry I’m a little bit lazy with the updates for my turris mox.

Today I did it.

Sadly not all worked fine, but the system info tells me it is updated to OS 6.2.4

But when I do the update command manually via ssh I got warnings>

root@turris:~# pkgupdate
INFO:Target Turris OS: 6.2.4
WARN:Requested package reforis-snapshots-plugin-l10n-de that is missing, ignoring as requested.
WARN:Requested package reforis-diagnostics-plugin-l10n-de that is missing, ignoring as requested.
WARN:Requested package reforis-haas-plugin-l10n-de that is missing, ignoring as requested.
WARN:Requested package reforis-data-collection-plugin-l10n-de that is missing, ignoring as requested.

Via Mail I got the additional information:

Error notifications
Updater execution failed:
runtime: [string \"requests\"]:432: [string \"utils\"]:443: Unable to finish URI (https://repo.turris.cz/hbs/mox/lists/base-conditional.lua): Download failed: Could not resolve host: repo.turris.cz"

But when I enter https://repo.turris.cz/hbs/mox/lists/base-conditional.lua or repo.turris.cz in the browser it can access the ressources.

Here an additional call I found in the forum, that might be interesting for you:

root@turris:~# opkg list-installed | grep reforis
reforis - 1.4.1-3.9-2
reforis-data-collection-plugin - 0.4.0-3.9-5
reforis-diagnostics-plugin - 2.5.1-3.9-4
reforis-haas-plugin - 0.1.4-3.9-1
reforis-l10n-de - 1.4.1-3.9-2
reforis-snapshots-plugin - 1.2.1-3.9-4
reforis-storage-plugin - 0.2.2-3.9-4

Can I ignore the warnings?


I got a weird errors with syncthing after changing the password in its UI. Cannot login unless i made an error - Seems there might be issue with bcrypt in syslog

Mar 10 19:39:18 turris syncthing[7258]: [TNGPE] 20:39:18 INFO: Wrong credentials supplied during API authorization from
Mar 10 19:39:18 turris : pam_unix(http:auth): unrecognized ENCRYPT_METHOD value [BCRYPT]
Mar 10 19:39:18 turris : pam_unix(http:auth): check pass; user unknown
Mar 10 19:39:18 turris : pam_unix(http:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
Mar 10 19:39:21 turris : pam_unix(http:auth): unrecognized ENCRYPT_METHOD value [BCRYPT]
Mar 10 19:39:21 turris : pam_unix(http:account): unrecognized ENCRYPT_METHOD value [BCRYPT]
Mar 10 19:39:22 turris syncthing[7258]: [TNGPE] 20:39:22 INFO: Wrong credentials supplied during API authorization from