Turris OS 6.0.2 is in the Testing branch

Dear Turris users,

We have been working on a hotfix release for Turris OS 6.0 series, and we prepared Turris OS 6.0.2. The changes, which are in this release, are below.

Release notes:

🚀 New Features
  • Added SSL variants for zabbix

📌 Updates
  • Updater-ng updated to 70.0.2
  • Rainbow updated to 0.1.2
  • Unbound updated to 1.17.0
  • igmpproxy updated to 0.3
  • tailscale updated to 1.24.2
  • uriparser updated to 0.9.7

🐛 Bug Fixes
  • Adjust path for tar in maintain-config-backup script
  • Fixed missing icon in reForis menu for Nextcloud plugin
  • Fixed collisions in ffmpeg packages
  • Fixed collisions in pulseaudio packages
  • Fixed collisions between ttyd and mosquitto packages
  • Fixed kmod-ipt-nathelper-rtsp package with Linux kernel 5.15
  • Fixed initial user creation for Nextcloud
  • Fixed Turris Diagnostics webs for Turris Shield

📦️ Other Changes
  • Foris backend for old data collection system uCollect was removed

This release is in the testing branch, refer to our documentation for more details, how you can switch there. As always if you find any bugs, please let us know.

1 Like

I noticed on http://192.168.1.1/cgi-bin/luci/admin/system/startup there is rainbow-animator and rainbow-button-sync marked as Disabled for auto startup. Is that correct / expected?
Omnia, 6.0.2 HBT, it was the same in clean install of 6.0.1.

I don’t know if is it related to this release, but this issue is fixed for me WebSocket connection to 'wss://192.168.1.1/foris-ws' failed (#387) · Issues · Turris / reForis / reForis · GitLab
using Chrome 107.0.5304.87.

Thanks for confirming! @mmtj and @Aleksan4eg noticed that last week that in Turris OS 6.0.2, the issue is fixed, but they forgot to update the public issue on GitLab. They discussed it on Mattermost, which we are using.

Update ok: Turris Omnia 2017, 1 GB RAM, dead eMMC, system running from mSATA SSD, original wifi cards. Storage plugin enabled, LXC containers, tor relay, USB HDD shared over samba4 and minidlna, SQM, Hardwario gateway + MQTT IoT bridge, OpenVPN, PPtP VPN.

Just one minor thing: I can’t dismiss notifications in Reforis (I’ve tried both the big button on Overview page and the smaller button in the popup). Notifications disappear when I click the button, but after I reload the page, they are back.

By the way, now that we have TOS 6.0 released, what is the state of bootloader and NOR memory on Omnias 2017? Should I run nor-update? Is it dangerous? Will it improve/fix something for me?

And what about making the reset modes work when booting from mSATA? Is there some progress with that?

Let’s sum here @Aleksan4eg, who will investigate it and tell you more. :slight_smile:

In my humble opinion, we are open source project, but sometimes we are not so open regarding communication, which I would like to improve despite all the things that need to be done.

Anyway, in one of my presentations, which I had, I was talking about global updating U-boot, rescue, and factory versions, which would definitely help us because each revision of Turris Omnia routers has different versions. You know it. We know it. The thing is that you might be aware of some DDR training issues which could happen.

Unfortunately, Marvell is not really helpful on this thing and we are using different RAM chips across boards. Thus, it makes it a little bit harder. We know that the latest U-boot version could or could not work on the older revisions. There might be cases when it works, but we cannot do it at least automatically for now until the issue is solved. The worst that could happen is that you need the serial console and flash the older version because, otherwise, the board will not work. There are no such DDR training attempts to tweak it and boot it as in older versions. Right now, we have open position for Linux kernel developer to join and help us with that.

2 Likes

So the takeaway about nor-update is “don’t do it unless you have a very good reason?”

3 Likes

Basically, that’s correct.

4 Likes