Turris OS 6.0.1 is now released

Dear Turris users,

We want to inform you that we are releasing a hotfix for Turris OS 6.0.0 release with one feature, which is quite unusual, but it was prepared and included in Turris OS 6.0.0, but it was not installed by default. This release contains some additional improvements for some packages, which were renamed or missing or dropped without replacement. The list is not huge, it tries to solve packages, which were reported to us like wireguard, etc. The issue was that these packages were installed in LuCI or using CLI and because of that, they needs to be removed manually, too. We can not remove your installed packages automatically, if they are missing.

Changelog for this release:

:rocket: New Features

  • Added standalone snapshots web

:pushpin: Updates

  • Python3 updated to 3.9.15

:bug: Bug Fixes

  • Fixed link for morce in package lists (Reported by @aker, thanks!)
  • Some packages like wireguard were missing/renamed in upstream
    • Provide smooth transition atleast for a few packages
  • Fix compatibility script for rainbow (Reported by @CIJOML , thanks!)

As always, we appreciate any feedback regarding this release

8 Likes

Any information you are willing to share what this feature does and how to use it?

2 Likes

I still have an issue with lighttpd – it starts and shows running. I can reach the address but there is no choice of apps.

/var/log/lighttpd/error.log (again) says

Renaming /etc/lighttpd/conf.d/letsencrypt.conf to /etc/lighttpd/conf.d/letsenrypt.conf.bak is a bypass making the WebUI work offering the choice of apps.
I encountered this behaviour also in TurrisOS-6.0.

Content of /etc/lighttpd/conf.d/letsencrypt.conf is:

I see this behaviour with my my modified version of lighttpd.conf (redirect to https) as well as with the delivered version from update.

The same configuration worked fine up to version 5.4.4.

1 Like

I found that the hard way, no idea how to get to it via UI.
look at http://your-turris.lan/snapshot

here’s how I found it

opkg list-installed | grep -i snap
opkg files turris-snapshots-web
cat /etc/lighttpd/conf.d/80-snapshots.conf
1 Like

Sure! We will need to update the doc, but I will leave that for someone else. :slight_smile:

There are two webs, primary done for support purposes, but they worth to be mention:

4 Likes

Both useful additions! I assume both have significantly less dependencies compared to reforis and hence might be helpful if reforis is unhappy for whatever reason?

1 Like

Hello,

I have just upgraded from 5.x.x (don’t remember exactly) to 6.0.1. When I visit the IP address of the router from a web browser, nothing loads. I’m getting:

'Unable to connect

An error occurred during a connection to .’

Same for HTTP and HTTPS.

‘service lighttpd status’ is ‘running’, ‘nc localhost 80’ and ‘…443’ won’t connect with ‘Connection refused’ and grepping netstat for 80 and 443 does not show anything listening on the two ports.

I restarted the router several times after the upgrade. Is the web GUI not loading expected? What could I check/configure to make it work?
Thank you.

2 Likes

On which router model did that occured?

Could you please take a look at following logs?

  • /varlog/messages
  • /var/log/lighttpd/error.log

Perhaps some “red flags” (warnings, errors and such) will be here, so we could investigate the issue further.

It’s an Omnia with 1GB of RAM:

# cat /etc/device_info 
DEVICE_MANUFACTURER='CZ.NIC'
DEVICE_MANUFACTURER_URL='https://www.turris.cz/'
DEVICE_PRODUCT='Turris Omnia'
DEVICE_REVISION='v0'

/var/log/lighttpd is empty. To be honest I’m not exactly sure what to look for in messages. Grepping for errors, warning, lighttpd returns:

# cat /var/log/messages | grep -iE 'lighttpd|err|warn'
Oct 21 19:27:21 turris kernel: [    0.000000] Registering MPIC SoC Error Interrupt Controller
Oct 21 19:27:21 turris kernel: [    1.882697] sdhci: Copyright(c) Pierre Ossman
Oct 21 19:27:21 turris kernel: [    9.413723] random: 31 urandom warning(s) missed due to ratelimiting
Oct 21 17:27:33 turris sentinel-fwlogs[5400]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:27:36 turris procd: Instance lighttpd::instance1 s in a crash loop 6 crashes, 1 seconds since last crash
Oct 21 17:27:40 turris sentinel-fwlogs[7799]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:28:05 turris sentinel-fwlogs[7803]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:28:45 turris sentinel-fwlogs[7869]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:29:16 turris sentinel-fwlogs[7892]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:29:26 turris sentinel-fwlogs[7949]: ERROR: Packet handling failed: Resource temporarily unavailable
Oct 21 17:36:15 turris updater[8126]: updater.lua:94 (Globals): Queue removal of fix-lighttpd-sync-with-upstream
Oct 21 18:28:06 turris sentinel-dynfw-client[2335]: ipset v7.6: Error in line 1: Element cannot be deleted from the set: it's not added
Oct 21 18:28:06 turris sentinel-dynfw-client[2335]: 2022-10-21 20:28:06,336 - WARNING - Error running ipset command: return code 1.

In the meantime I’ve also discovered that the web-interface of Pi Hole that I run in an Ubuntu LXC container on the Omnia isn’t reachable either after the upgrade. DNS service (provided by Pi Hole) however works in my network.

I was getting a strange boot loop today. I could rollback and it would work until the update process would run and then start boot looping. I reset to factory and now am stuck trying to do the update from 3 to 5.0.

root@turris:~# pkgupdate
cat: can't open '/usr/share/server-uplink/registration_code': No such file or directory
WARN:Contract wasn't verified
WARN:Package wpad is in cyclic dependency. It might fail its post-install script.
WARN:Package hostapd is in cyclic dependency. It might fail its post-install script.
WARN:Package vim-full is in cyclic dependency. It might fail its post-install script.
WARN:Package vim is in cyclic dependency. It might fail its post-install script.
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
INFO:Queue install of libgcc/turris/8.4.0-3
INFO:Queue install of libc/turris/1.1.24-3
INFO:Queue install of tos3to4-earliest/turris/2.4.1-54
INFO:Queue install of libjson-c/turris/0.15-2
INFO:Queue install of libubox/turris/2021-05-16-b14c4688-2
INFO:Queue install of jsonfilter/turris/2018-02-04-c7e938d6-1
INFO:Queue install of busybox/turris/1.33.2-3
INFO:Queue install of ca-certificates/turris/20210119-1
INFO:Queue install of base64c/turris/0.2.1-4
INFO:Queue install of libopenssl/turris/1.1.1q-1
INFO:Queue install of libexpat/turris/2.2.10-2
INFO:Queue install of libbz2/turris/1.0.8-1
INFO:Queue install of libpthread/turris/1.1.24-3
INFO:Queue install of liblzma/turris/5.2.5-3
INFO:Queue install of zlib/turris/1.2.11-6
INFO:Queue install of libarchive/turris/3.5.1-1
INFO:Queue install of liburiparser/turris/0.9.6-2
INFO:Queue install of ca-bundle/turris/20210119-1
INFO:Queue install of libnghttp2/turris/1.43.0-1
INFO:Queue install of libcurl/turris/7.83.1-4.1
INFO:Queue install of libevent2/turris/2.1.12-1
INFO:Queue install of liblua/turris/5.1.5-9
INFO:Queue install of libuci/turris/2021-04-14-4b3db117-5
INFO:Queue install of libuci-lua/turris/2021-04-14-4b3db117-5
INFO:Queue install of updater-ng/turris/70.0.0-2
Press return to continue, CTRL+C to abort

INFO:Executing preupdate hook: 05_schnapps.sh
Snapshot number 453 created
INFO:Unpacking download packages
INFO:Checking for file collisions between packages
line not found
line not found
line not found
line not found
line not found
line not found
DIE:
[string "transaction"]:334: [string "transaction"]:158: Collisions:
• /usr/bin/killall: busybox (new-file), psmisc (existing-file)
• /usr/bin/xz: busybox (new-file), xz (existing-file)
• /usr/bin/flock: flock (existing-file), busybox (new-file)
• /usr/bin/diff: busybox (new-file), diffutils (existing-file)
• /usr/bin/cmp: busybox (new-file), diffutils (existing-file)
• /usr/bin/unxz: busybox (new-file), xz (existing-file)
Aborted
1 Like

@Jon_Lundy start fresh from medkit dont try to upgrade from 3 to 6. Less possible problems.

Also this bug VLAN filtering broken in kernel 5.15.x (hbl) (#355) · Issues · Turris / Turris OS / Turris Build · GitLab was milestoned to 6.0.1 is there any chance someone is working on it?

I am proud to announce that today’s upgrade to TOS 6.01 went perfectly without assistance. Unlike yesterday’s 6.0 update, when my Turris 1.1 became non-functional and only manual installation helped. Thanks, good job!

2 Likes

Ahoj, jen upozornuju, ze ani v 6.0.1 rainbow nefunguje:

root@turris:/etc/cron.d# /usr/bin/rainbow intensity 5
Command failed: Not found
Command failed: Not found
root@turris:/etc/cron.d# cat /etc/turris-version
6.0.1

1 Like

These both appear not to be protected by authentication here, at least not from the internal network. In the first case this could be an information leak. In the second case one who has access to internal network could delete all snapshots without permission. I would prefer for these two to be protected by authentication.

1 Like

They’re protected by the new unified login. Just try from a fresh browser or something.

1 Like

Ah, seems I did not close all of the browser windows, yes, verified, they are protected. Thanks!

In my testing I am greeted by a “enter password” field on a fresh browser.

I’m getting the following error trying to access Luci:

/usr/lib/lua/luci/dispatcher.lua:427: /etc/config/luci seems to be corrupt, unable to find section 'main'

The section in question looks like this:

config core 'main'
	option lang 'auto'
	option mediaurlbase '/luci-static/bootstrap'
	option resourcebase '/luci-static/resources'

Any ideas?

Update without problems on my Omnia. State of the router was good even after update and before reboot. No wifi or wan interruption.

1 Like

This is not a Turris OS problem, but merely an FYI for anyone who has access to LuCI enabled from behind a reverse proxy (eg: nginx etc). There is now an additional path configuration you’ll need to add to your reverse proxy to enable some of the functions of the LuCI app.

Particularly, the Software admin page (/cgi-bin/luci/admin/system/opkg), I was getting 404 errors with the page calling a new (to me) cgi-exec path at: /cgi-bin/cgi-exec.

Edit: added /cgi-bin/cgi-download as used by /cgi-bin/luci/admin/statistics/collectd

The fix is as simple as adding the new cgi-exec path to (nginx) config:
#Turris Omnia LuCI
location /cgi-bin/luci {
proxy_pass http://internalip:80;
}
location /luci-static {
proxy_pass http://internalip:80;
}
#Added for upgrade to Turris 6 (OpenWRT 21)
location /cgi-bin/cgi-exec {
proxy_pass http://internalip:80;
}
location /cgi-bin/cgi-download {
proxy_pass http://internalip:80;
}