Turris OS 5.2.3 is released!

Dear Turris users,

After two days in the testing branch, we released Turris OS 5.2.3 to all of you!

In this release, we prepared a few things like:

  • New version of Updater
    This includes a more technical point of view why some messages why download was not successful.
  • Related fixes to install Nextcloud
    Since now, you will be able to install and configure additional applications from Store.
  • Updated Knot Resolver and Unbound to improve scheduling priority.
  • Updated nano to version 5.8

The router will download and apply this update automatically if you haven’t changed the default configuration. If you do, you should check the Updates tab in reForis to proceed with this update.

Do you find any bugs or regression caused by this update? Don’t hesitate and reach our technical support department


Mox no problems with this one… So thats good ! :slight_smile:

Installed but with error notification:
Updater failed: [string “transaction”]:327: [string “utils”]:151: Failed to stat ‘//srv/www/nextcloud/ocs’: I/O error

After re-execution of the updater: “Fixed Nextcloud installation in Web UI. Fixed AppStore in Nextcloud”

But still not able to open Nexcloud: “404 Not Found”.

Reboot did not help. Any advice, how to fix this?

Thank you

Same here, 5.2.3 did not require hard reboot, as opposed to 5.2.1 and 5.2.2… all good… :slight_smile:

1 Like

just remotely rebooted the mox, and that did not go well… had to go there, and hard reboot…so there still is something dodgy.

Thanks, the update itself went fine. I had some issues with DDNS after the reboot, but I am not 100% certain these were caused by the update; restarting the DDNS service (by clicking the “PID…” button in the LuCI DDNS management page resulted in working DDNS again.

Hi, many thanks for the update. For some reasons I just lost my luci :slight_smile: All I get on main gui page is file called: download (doesn’t matter if http or https).

EDIT: I will move this to a separate topic. Probably this is not a good place for asking :slight_smile:.
EDIT2: This problem has been moved to a separate topic Luci offers only a 'download' file

Update was smooth on my MOX A+D basic conf no extras.
No need for reboot so I have not tested that yet.
Will switch to persist logs before I do.

I’m using Netxtcloud 19.0.3 with TOS 5.2.3
Can I update Nextcloud with the built-in updater?
Will it break Nextcloud with future TOS updates?

Hello @Kes,

This is something wrong with the device, which is mounted on /srv. There can be several reasons why it happened - the disk is full or the file system is read-only, etc. It would be best if you reached our technical support department, and they will help you with this issue. :+1:

No, this is not recommended for now.

Yes, because we manage the Nextcloud version, and it is updated only in minor versions like Turris OS 5.2 and Turris OS 5.3. Otherwise, the update will take a long time in fixup releases, which I do not favor doing that. While I was testing it, the Nextcloud update took almost ~30 minutes, but this varies a lot on the external device you use for Nextcloud.

In the future, we want to provide Turris users only install script for Nextcloud, and then they can manage it themself when they want. This will avoid situations when users updated it to the latest version, and we updated it to a newer version, which caused the downgrade (e.g., from 20 to 19), which is not good.

Blue Turris 1.1 update successful :grinning:

Thank you!

My MOX-update was successful.

older Part - obsolete

however the bug with the following error-message is back:

Error notifications
Updater failed: 

runtime: [string "requests"]:430: [string "utils"]:422: Unable to finish URI (https://repo.turris.cz/hbs/mox/lists/base.lua): Download failed: Couldn't resolve host 'repo.turris.cz'

I will report this also in the corresponding gitlab-thread.
I must have something to do with this update as my TO 1GB is still on an older version and doesn’t show this behaviour.
Edit: I had a wrong forwarding IP for DNS configured in /etc/config/network

Why making it so hard to find it? Just link it in your post :slight_smile:

I’m sorry - I didn’t have it at hand. Here you are: Updater Failed (#1) · Issues · Turris / Turris OS / Turris updater lists · GitLab

1 Like

Hi together,
just did the upgrade from 5.1.9 to 5.2.3 and it worked smoothly but i actually found out a bit later that 6 of my 18 DHCP static lease got lost after update. I had to add them again and of course restart the clients to get the new leases applied :frowning:
Is that known?