Turris OS 5.1 is out

Is this update split to two parts that I have to confirm separatelly? First one removed mdadm and second one wanted to install it back, but waited for my confirmation.

@Pepe have found two bugs in 5.1 which should be looked at. One has an easy fix, the other I don’t know what’s up.

foris and reforis log error to /var/log/messages on almost every pageview in TOS 5.1

sentinel-nikola not running properly in TOS 5.1

1 Like

Most likely, you had installed mdadm in localrepo and while looking at your output the versioning of mdadm does not look right. There should be just 4.1-2

root@omnia:~# opkg install mdadm
Installing mdadm (4.1-2) to root...

Yep, i have the same lines in the syslog. I see it is missing a line in the script? Can that be fixed by hand or do we need to wait for a update?

I have no idea what was wrong. But It works now. :+1:

3 posts were split to a new topic: Tcpdump-mini and tcpdump collision

4 posts were split to a new topic: microSD card and corrupted FS

haas-proxy wasn’t running after 5.1.0 upgrade (first part of upgrade did uninstall it).
I’ve had to enable haas-proxy manually
(I was upgrading from 5.0.3 if this is the culprit)

@DIKKEHENK from looking at the bugs the upcoming fix will change the beginning of /lib/functions/sentinel.sh to look like this. It’s the same as what I proposed but it checks first to see if the functions have already been defined in another script. Tested and it corrects the issue.


# source OpenWrt functions if not sourced yet
command -v config_load > /dev/null || . /lib/functions.sh
1 Like

hi there, bit of a nOOb here…but should it look like this?


# source OpenWrt functions if not sourced yet
command -v config_load > /dev/null || . /lib/functions.sh
allowed_to_run() {
	local component_name="$1";
	agreed_with_eula "${component_name}" && component_enabled "${component_name}"


@DIKKEHENK either remove the line

source OpenWrt functions if not sourced yet

or put a hash symbol in front of it lilke this

# source OpenWrt functions if not sourced yet

It’s a comment in the code, so either delete it completely or mark it as a comment with the hash symbol. Otherwise looks OK

Yes, that # got lost in posting.

But it is put just below the #!/bin/sh ?

Syslog shows no error now :)…yet.

edit, works! Thxs!

Aug 28 21:01:01 turristhuis sentinel_nikola: Logrotate took 0.087390 seconds
Aug 28 19:01:01 turristhuis crond[14366]: (root) CMDOUT (Logrotate took 0.087390 seconds)
Aug 28 21:01:02 turristhuis sentinel_nikola: Syslog parsing took 0.219289 seconds
Aug 28 21:01:02 turristhuis sentinel_nikola: Records parsed: 310
Aug 28 19:01:02 turristhuis crond[14366]: (root) CMDOUT (Syslog parsing took 0.219289 seconds)
Aug 28 19:01:02 turristhuis crond[14366]: (root) CMDOUT (Records parsed: 310)
Aug 28 21:01:02 turristhuis sentinel_nikola: Sending records took 0.004145 seconds

Yes that’s correct, just below #!/bin/sh

The cron only runs once every 15 minutes so you won’t see if it worked until then.

1 Like

I also like to mention this line that keeps popping up… any idea?

turrisXXXX haas-proxy-start[20570]: 2020-08-29T09:30:18 CRITICAL twisted ‘channel open failed, direct-tcpip is not allowed’

you must have installed the SSH honeypot (haas-proxy) This puts a fake SSH endpoint for people outside your network to try to login to, attempts to login to this are logged and sent to nic.cz so they can analyze patterns of people attacking Turris routers. Warning is harmless, just means someone is trying to connect to the proxy in a way it doesn’t support.

yes, installed it, including token. Works by the way. And i also see there was a 2 year old github ‘bugreport’ that mentioned this.


I had a same issue with mdadm as you had. Nevertheless now works fine…

If you have update approvals then you have to approve it twice because of package list reorganization we did. Initially update is unaware of some of those packages so it removes them but subsequent update request should install them back.

Any word on the auto update from the 3.x branch yet?

You can trigger migration if you want. There are blockers still before automatic migration is released.

1 Like