Turris OS 5.1.2 is out!

Dear Turris users,

It is a pleasure to let you know that we released Turris OS 5.1.2 from the Testing branch.

Release notes for Turris OS 5.1.2:

  • Changed priority of port forwarding for data collect firewall to not overrule user’s rules.
  • Fixed issue with data collect firewall logs collecting in some cases causing high system load

In this release, you can find also security updates (e.g. mariadb, if you are using Nextcloud), regular package updates and we bumped config file of syslog-ng, which was mention in Turris OS 5.1.1 thread.

If you are using automatic updates, you will be updated to this version soon and when you are using approvals, check Updater tab for notification.

As always, we are looking for feedback from this release.

5 Likes

hmm, have 2 fw rules that does not seem to work after this update? might be my fault, but before they worked?

best, dikke

ps, send cynerd the diag and the iptables-save output.

Can you please send firewall diagnostics to support or send me here output of iptables-save?

Mox A + D
Smooth upgrade - thank you turris team!

1 Like

Which kind of SFP module you are using?

That applies for user rules set via luci, right?

As the transceiver in the switch supplied by my fiberoperator did not work, and I did not want to reburn the eprom I searched for a cheap replacement.
I bought mine from a swedish webshop as it was really cheap, this worked fine for me but it is no guaratee it will work for others…
Note that you could damage the otherside of the fiberlink if you do not know what data you should look for.

This is the one I have
https://www.direktronik.se/direktronik/natverk/sfpgbicxfpcwdm/sfp-1g/sfp-bidi-wdm-tx1310rx1550-sc-singlemode-20km-lx-1.25gbps/?variationCode=133-2395

Im not very technical, but im happy with this update. Seems like everything runs smoother and is more stable.

Is what mentioned in the first post the complete changelog? If not where can I find the complete changelog?

I am trying to update from turris 4.0 beta 1
So far I had no success.
In my latest try I tried to force manually but it does show good result.

Edit: Sorry for the noise. 5.1.2 Installed and running. Update are not working if the router is not setup through wan. Otherwise works well.

Try medkit instead.

https://docs.turris.cz/hw/mox/rescue_modes/#re-flash-router

Unfortunately, this does not belong to this thread. You have already your own one. In any circumstances please take a look here:

As usual, there is no RAID service running after autoupgrade. Manual start and voila, it works fine and following reboots starts mdadm automatically. I do not know why after autoupgrade no mdadm running when after reboot it does. There was a same issue eve in previous autoupgrade… It is quite challenging as many of my services depend on running RAID.

HI!

If the issue is not reporting to us as it should (via Gitlab issue, support department), we don’t know about it. Some threads have many posts and bug reports here can slip through. For bugs and tracking them, we are using Gitlab. You can check our support article or contributing one.

We need to know what is going on and outputs can be useful.

Could you please try the following command: /etc/init.d/mdadm enable if this is going to work for you or you could even see in LuCI in Startup tab, which services are enabled or disabled one. If it is enabled, it means that the service is going to start after a device reboot and if the app crashes it will autostart it.
If you are not familiar with GUI, you could check folder /etc/rc.d.