Turris OS 5.0 is released!

Use latest medkit + switch-branch hbt

Thanks for this release!


  1. pkgupdate was stuck at ddns-scripts postinstall. I fixed it by removing luci-app-ddns and ddns-scripts temporarily (I think this is a known bug as it occured in TOS 3.X some time ago, too).
  2. Wrong kmod-ath10k got installed (I changed ath10k firmware to ath10k-firmware-qca988x-ct-htt), fixed by running opkg remove kmod-ath10k && opkg install kmod-ath10k-ct

12 posts were split to a new topic: Adblock troubleshooting

@pepe Thank you for the release of Turris OS 5.0.

I’m still getting this error, even after uninstalling acme and all dependent packages. Any idea what could be going on here?


Thanks for the all the effort put into this upgrade. I’d like to ask a question before applying it, though. There’s something in the release notes that worries me slightly:

  • Removed sysupgrade from the system as it is dangerous.

I have backup scripts that heavily rely on sysupgrade to dump the configuration of the router when I change things. I have to confess that I don’t use Foris much and that all the configuration changes to the device I perform are either via Luci or the console (uci) so sysupgrade -b is basically everything I need to backup the configuration to external storage. No having it is… a problem.

I’d like to know if it’d be possible to get it back by installing it manually after the upgrade. Querying with Opkg on 4.0.5 it seems that it’s shipped via base-files so the chances that I cannot have it installed on 5.0 are quite high I imagine. Was it actually wiped from base-files?

Could anybody please shred some light on this? Thanks!

Oh, yes: https://gitlab.labs.nic.cz/turris/turris-build/-/merge_requests/145/diffs

This is bad. IMO if you wanted to protect users the script should have been moved away from the $PATH instead of wiping it out, perhaps? :frowning: Any chance you could bring it back in 5.0.1 in a different location in the filesystem not in the $PATH?

You could use schnapps export as an alternative, it creates a tar.gz file of your current root filesystem (or defined schnapps snapshots) that you can browse manually or even import to rollback:

schnapps import <file.tar.gz>
schnapps rollback <snapshot id shown by command above>
1 Like

Thanks. I’ll use maintain-config-backup | base64 -d > $something.tar.bz2 in the meantime.

2 posts were split to a new topic: Netdata can not open file shm in proc

Yup, exactly the same thing. Wi-Fi broken, reboot fixed it. No wget on the system after rebooting so opkg is broken basically.

Collected errors:
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/core/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/base/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/cesnet/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/luci/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/node/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/openwisp/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/packages/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/routing/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/sidn/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/telephony/Packages.gz, wget returned 255.
 * opkg_download: Failed to download https://repo.turris.cz/hbs/omnia/packages/turrispackages/Packages.gz, wget returned 255.
~ # opkg install wget
Package vim-fuller version 8.0.586-2.37 has no valid architecture, ignoring.
Package vim version 8.0.586-2.18 has no valid architecture, ignoring.
Unknown package 'wget'.
Collected errors:
 * opkg_install_cmd: Cannot install package wget.
~ #

I had to download the package by hand, scp and install it.

opkg does not require wget but leverages client-fetch instead.

opkg install gnu-wget may work instead, see https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/599

1 Like

Thanks for the pointer! My point was though that the system was left in a bad state, IMO. I wouldn’t have expected to have a non-working opkg to be honest :stuck_out_tongue: uclient-fetch was installed on the system and opkg was still trying to use wget.

Sounds a like a leftover symlink depending on how you arrived at TOS5.x, though not sure how that might have happened or that it should have happened at all.