Turris OS 4.0 is out!

Dear Turris users,

we just released an important milestone - Turris OS 4.0. This is the release based on OpenWrt 18.06 that spent quite some time in various forms of testing. It completely changes how we make our releases and we are now much closer to the upstream then we’ve ever been. Everything had to be rebuilt from scratch so it was a huge task to move away from the old way of doing stuff and we took the opportunity to get rid of some of the skeletons in our closets.

Because of that, some of the features available in 3.X are still not present in 4.0. But because 4.0 is the new main development branch, it also has some features not present in 3.X.

What is not there yet

  • samba4 not back-ported
  • cloud backups
  • ability to configure various honeypots and security data collection from web UI

What we are still working on

  • reboot issue on some Turris MOX boards - so far we had no luck to pin down the exact cause and fix it
  • migration from Turris OS 3.X
  • support for Turris 1.X

What is new there

  • updated storage plugin with experimental multi-device and Nextcloud support
  • newer everything (kernel, base upstream distribution, various packages)
  • network interfaces management in Foris

If you have Turris Omnia router with Turris OS 3.x and would like to have Turris OS 4.0 on your router and configure it from scratch, you need to download medkit to USB flash drive, which should be formatted to filesystem EXT2/3/4. You don’t need to extract the medkit, just move it there and once it finished, plug it to the router. By using re-flash method (4 LEDs), it will erase all the current data and you should have Turris OS 4.0 release.

As always, your feedback is welcome!
Your Turris team

12 Likes

Great to see that Turris OS 4.0 is released. Just to mention that i (coming from a Turris OMNIA) had to activate SFP module with the following command
ln -sf armada-385-turris-omnia-sfp.dtb /boot/dtb && reboot thanks @n8v8r who mentioned this in one of the beta threads.
Would be nice to add this information into the release notes.

Congratulations on the 4.0 release!

Can you please include supported 3G/4G modules and tools in 4.0 medkit package for simplifying 3G/4G-only WAN usecase setup

Additional packages required for Quectel EC-25 are:

  • kmod-mii
  • kmod-usb-net
  • kmod-usb-net-qmi-wwan
  • kmod-usb-wdm
  • luci-proto-qmi
  • uqmi
  • wwan

Currently, after manually downloading (https://repo.turris.cz/hbs/omnia/packages/) and installing the ipk packages via command line, it was possible to configure lte interface in luci and after reboot lte connection started working

with best regards,
Martin

Could you enable kernel config option for CONFIG_BRIDGE_VLAN_FILTERING=y?

I did notice something “strange”. I was on my tablet and tried to update from TOS 4.0 B11, to TOS 4.0, the SSID that i was on, was turned off. This was kind of strange to me, because in the past from alfa 1 tot other alfa versions to beta’s and between beta’s i used this exact way to update.

Now i had to turn my laptop on (which is connected by cable) to go in to Foris to press the reboot button.

Btw, everything works so far.

It had the same issue. Had to connect to my Omnia 4.0beta11 after update to 4.0 by LAN to reboot.

Same weird issue on my MOX as on beta-11: Third Wi-Fi is detected whereas only 2 cards are physically installed (see also here and here).

I don’t know if this might be related: At the very first attempt I accidently connected my modules in the wrong order: P-A-B-G. This time only the Wi-Fi-card inserted into the B-module was detected (expected behavior as the PCIe-chain ends with a B-module). I then powered of my MOX and rearranged the modules to P-A-G-B. After that the existing 2 cards are detected plus the ghost-card that does not exist…

What’s the upgrade path from TOS3? Is it documented somewhere?

1 Like

How to upgrade from TO 3.0?

perhaps read once again:

What about CPU ports support? Can I use eth0 eth1 and eth2?

So it become official. I am preparing to move to TOS4.0!

We are still working on automatic migration from Turris OS 3.x. When it will available for advanced users, there is going to guide how to migrate it manually before it is done automatically, but it all depends on your setup. Most likely you would not be able to restore the configuration from Turris OS 3.x as there are some changes e.g. in the name of interfaces and so on.

If you would like to have Turris OS 4.0 on your router right now, you need to use reflash method as described in our documentation.

1 Like

In the past, there was used swconfig for switch configuration, now there is used Marvell Distributed Switch Architecture (DSA) with multi CPU support. With this change, there needs to be some changes in the name of interfaces.

For wan, there is eth2 instead of eth1.
For lan ports, you can see them as lan0-lan4.

All ports are working as they should. You can use names which you want, but I wouldn’t suggest renaming wan interface to something different.

Thaks! So on URL https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz is now TOS 4?

Yes, this link is for Turris OS 4.0, which is now designed as patch set for OpenWrt. Basically, it means that Turris OS 4.0 is based on top of OpenWrt 18.06 with our patches and feed. If you wish to use a newer version of OpenWrt, which was not released yet, or you would like to even have daily builds on your routers as OpenWrt has, you can. For more details just take a look at the command switch-branch, it will show you more details when you configure your router and SSH into it.

2 Likes

is there any estimation when we could expect the migration work will be ready?
I also use my TO as a NAS, is there no issue with NAS functions and NFS in TOS 4.0?

No need to get snarky, this is a legitimate question.

Nothing on this thread, which is the one announcing the actual release of TOS4, indicates how to proceed to upgrade or even to install fresh.

What are the options? What are the caveats? Can I “dual-boot” both versions? These are all valid questions when a release announcement comes out.

1 Like

Thanks, that’s the information I needed (with the link to the medkit that @michal posted).

Just installed from TO 3.0 using medkit and everything work fine. Good job.