Turris OS 4.0 beta11 is released!

Dear Turris users,

We are releasing Turris OS 4.0 beta11 from Testing branch to Stable for Turris MOX and Turris Omnia routers. There are two changes in this release.

  • mariadb: Updated to the version 10.4.8.
  • kernel: Updated to version 4.14.142.

You should be updated to this version automatically if you are not using approvals. If you do, you should get a notification also you can check it in Updater tab, where you can approve the update.

If you have Turris Omnia router with Turris OS 3.x and would like to configure your router from scratch to give a try Turris OS 4.0 release, you need to download medkit to USB flash drive, which should be formatted to filesystem EXT2/3/4. You don’t need to extract the medkit, just move it there and once it finished, plug it to the router. By using re-flash method (4 LEDs), it will erase all the current data and you should have Turris OS 4.0 release.

We appreciate any feedback regarding this release.

3 Likes

… for Turris Omnia and Turris MOX routers …

1 Like

Oops! Thanks. Fixed.

Works for me (nextcloud database issue is resolved).

1 Like

I tried out Turris OS 4.0b11 on my Omnia, however I couldn’t get internet to work.
In 3.11.7 I had my WAN bridged with eth1.300 (my provider uses vlan 300 for internet). And that works.
In Turris OS 4 I tried various things, bridging WAN with eth0.300, eth1.300 and eth2.300 but none worked.
Is vlan not supported in this beta yet? Because I also noticed that ‘switches’ is absent under the Network tab in LuCi.

Will TO users still on 3.11.7 be automatically updated to version 4? And if not, can I restore my version 3 settings after I install version 4?

Search for buzzword DSA in this forum - VLAN will be handled completely different in TOS v. 4.x upwards.

1 Like

@ Powerburner

I have the same problem. The solution ( in Luci ) is to make a new WAN interface.
/cgi-bin/luci/admin/network/network
set current WAN interface protocol to unmanaged.
add new interface
name =wan2
In general setup protocol = PPPoE
use your user & pass
Advanaced setup force link = activated.
Physical setting > interface >scroll down> make custom eth0.300
firewall setting > WAN.

that should work for a PPPoE.

not sure what your outside connection is?

1 Like

We are working on automatic migration from Turris OS 3.x to Turris OS 4.x release. It all depends on your configuration. I wouldn’t restore the configuration as there are some changes in the name of interfaces and so on. It will be better if you can take a look what is different and apply it by hand.

TOS 3.x and TOS 4.x are based on different OpenWrt releases and therefore there are few differences in Luci. For example the missing “switches” in Network tab. You have to set it like @DIKKEHENK wrote.

Vlans are supported, however you can’t set them in Foris.

that should work for a PPPoE.

I tried that setup and that way it should work either with or without PPPoE.

I have a fiber connection. The SFP module is directly connected to the SFP port of the omnia. I will try your suggestion by making a new WAN interface. I’ll let you know if that solved my issue. Thanks for the help so far. :slightly_smiling_face:

I noticed that the link to the medkit in your opening post is in https://repo.turris.cz/hbs/medkit/ and the size is 35MB. The medkit in https://repo.turris.cz/omnia-stable/medkit/ is 55MB, what’s the main difference? I just wonder where the 20 MB size difference comes from.

Are you aware that TOS4.x does not provide automatic SFP detection/switching/activation? It is mentioned in some forum post(s) how to switch to SFP manually.

I didn’t know. I searched and found some mention about using 2 device trees and Uboot detecting which one to use upon booting the Omnia. I haven’t found the post on how to manually switch to SFP yet.

1 Like

Thanks for the help so far. I’ll give it a go.

I executed the command from SSH, I saw the omnia reboot and then I made the interface etc etc. But I still don’t get an IP from my provider.

I noticed this in my kernel log, so I think this means it’s using the SFP module?


I think I’ll flash back to 3.11.7 for now and wait for the stable version to release.

Maybe temporary problem with internet connection on my side, I don’t know:

Error from 2019/09/21 20:41:37

Updater failed:

runtime: [string “requests”]:395: [string “utils”]:429: Unable to finish URI (https://repo.turris.cz/hbs/omnia/lists/base.lua): Download failed

ok, running b4.11 on an mox classic.

problems with :
-After a reboot, adblock & pakon does not restart itself. needs to be done by hand.
-the collecting FW data ( activated ) does not show up in the syslog, nor in Foris. Also there is no connection in the syslog to the mothership like with the omnia .
-the honeypot ( when activated ) does not work , or is not seen in the syslog, nor in Foris.
-also have speed issues. Up Down is 500/500 here ( fiber ) . Mox has very variable up and down speed, and the down speed is the most variable. From 200 to 424…
best, DIKKE