Turris OS 4.0 beta1 is released!

release

#21

Sure. You proposed it, we considered, and we will do that change.
This is how it should work, right? :wink:


#22

After uncheck DE language and run updater I got this notification:

Error from 2019/05/03 14:16:28
Updater failed: Failed operations:

cznic-repo-keys-test/postrm: mount: mounting on /tmp/certstore failed: Invalid argument

umount: can't unmount /tmp/certstore: Invalid argument 
Update from 2019/05/03 14:16:28
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-veth
• Installed version 2.1.1-2.0 of package lxc
• Installed version 2.1.1-2.1 of package liblxc
• Installed version 2.1.1-2.8 of package lxc-common
• Installed version 2.1.1-2.1 of package lxc-attach
• Installed version 2.1.1-2.1 of package lxc-stop
• Installed version 2.1.1-2.1 of package lxc-start
• Installed version 2.1.1-2.0 of package lxc-auto
• Installed version 2.1.1-2.1 of package lxc-console
• Installed version 2.32-2.0 of package flock
• Installed version 2.1.1-2.8 of package lxc-templates
• Installed version 2.1.1-2.8 of package lxc-hooks
• Installed version 2.1.1-2.8 of package lxc-configs
• Installed version 2.1.1-2.1 of package lxc-create
• Installed version 2.1.1-2.1 of package lxc-info
• Installed version 2.1.1-2.1 of package lxc-ls
• Installed version 2.1.1-2.1 of package lxc-monitor
• Installed version 2.1.1-2.1 of package lxc-monitord
• Installed version 2.1.1-2.1 of package lxc-snapshot
• Installed version 2.32-2.0 of package getopt
• Installed version 20171206.2 of package rpcd-mod-lxc
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-lxc
• Installed version 2.32-2.0 of package blkid
• Installed version 2.32-2.8 of package partx-utils
• Installed version 3.1.3-1.1 of package rsync
• Installed version 8.23-3.1 of package coreutils-stat
• Installed version 0.2.5-3.6-1.0 of package foris-controller-storage-module
• Installed version 1.4-3.6-2.8 of package foris-storage-plugin
• Installed version 1.4.21-1.1 of package gnupg
• Installed version 1.4.21-1.6 of package gnupg-utils
• Removed package user-notify-l10n-de
• Removed package luci-i18n-base-de
• Removed package cznic-repo-keys-test
• Removed package luci-i18n-commands-de
• Removed package foris-diagnostics-plugin-l10n-de
• Removed package foris-l10n-de 

#23

Good job, MOX Super Wired started to work as expected.


#24

Does short term mean it is planned/hoped to be ready for 4.0 final?


#25

I’m currently running alpha4 on the hbt branch, and have run an upgrade, but unfortunately after updating to beta1 DNS is completely broken and doesn’t resolve any addresses at all. Done some research myself, but can’t spot anything obvious. I’ve also tried restoring the resolver config to default without any success. I’ve created a diagnostics file that I can PM if anyone could have a look to see if this can be resolved without having to do a factory reset.

EDIT: Seems that there’s actually nothing wrong with the update, the MAC address of the wan interface was changed (from eth0 to eth2), and my ISP requires that you add new MAC addresses to an allowed list. You are supposed to be redirected to this page when it detects a new MAC, but the DNS I got from them doesn’t support DNSSEC which caused the page to fail to load. All sorted now, and sorry for the confusion!


#26

Would you please send it to us to email address tech.support@turris.cz? All inquiries about Turris OS 4.0 are handled with high priority. You will receive a reply by Monday at the latest.


#27

OK, took the plunge and installed 4Beta1. Upgrade went without problems. Configuration with new Foris is more stable than with the old one.

Al seems to work OK with the exception of PnP. Clients that work without problem under 3.11 can’t configure the router under 4Beta1. Is this known?


#28

I ran against the problem of ntp preventing the beta 1 to be installed. It had some sort of a collision. I had installed ntpd so i could use the Omnia as a time server for my other network devices to point at.

Collision

Updater selhal:

[string “transaction”]:326: [string “transaction”]:153: Collisions:

• /sbin/ntpd: busybox (new-file), ntpd (existing-file)

I removed both of these and i could update.

ntp-utils
ntpupdate

EDIT: Btw, i can confirm that systemctl still does not work on a existing Ubuntu 18.04 LXC.

systemctl start deluged.service

root@K-Router-LXC:~# systemctl start deluged.service
System has not been booted with systemd as init system (PID 1). Can’t operate.


#29

Got PnP working. The service “miniupnpd” is not started despite that “start upnp service” is selected in Luci. A manual start of the service corrects this.
Didn’t we have a similar issue with one of the 3.11 version?

Otherwise 4Beta1 seems to run fine.


#30

We run something like this at work. For this case, DNSSEC will always break since all the DNS is redirected to a single or a handful of IPs for every hostname.


#31

Created issue on our Gitlab - https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/374.

This one could happen in some situations. However, it should be stable in all of our releases. What you can notice now that there’s a newer version of Foris & friends in Turris OS 4.x, which may include some fixes for bugs, which was reported to us in Turris OS 3.x. It willl be same in Turris OS 3.11.5 once we release it. It is possible that there will be even a newer version. This all depends when we release a new version from our development branches.

The described how to in Installing ntpd on TurrisOS? doesn’t work for you? However, we will look at it if there’s anything what we can do about it.

@miska is working on it! I can not tell if it will be included in the upcoming release as we would like to test it as much as possible as we want to send it OpenWrt as well. We’re working to have the latest LTS version of LXC which is 3.0.3 supported until June 2023 instead of 2.1.1, which is no longer supported by upstream and this old version is in OpenWrt.

There must be a different issue as the fix is included in OpenWrt 18.06 and also in Turris OS 4.0 as it is based on top of that release.


#32

Guest WIFI is missing IPv6 config. I only went through the Wizzard, no other config changed.
IPv6 assignment length is Disabled y default on GUEST_TURRIS interface.
It was the same in version 3.x.
My IPv6 provider is 6in4 tunnel by Hurricane, but I don’t think this would be the cause.


#33

Well, the only thing i did was a 4 LED reset, went through the Foris setup (as router), and checked the “Luci extensions” at the end (wait for installation of course) . After enabling “start upnp service” in Luci I had to manually start “miniupnpd” to get PnP to work.
I can’t imaging I did something to prevent the miniupnpd from automatically running.


#34

I don’t know if it is important but i just noticed it.

When using a network scanner TO with 3.11.x always reported the MAC vendor as “CZ.nic z.s.p.o.”.
Since upgrading to 4Beta1 it reports it as “Compex Systems Pte”.


#35

Oh… now, it’s very clear to me, where is the issue. The enable it means that it will enable service autostart (after boot), but it won’t start the service right now. If you want to the service right now, there’s button start.


#36

We don’t have support for IPv6 in Guest Wi-Fi, yet. It is possible that in the future, we will add it, but for now, it doesn’t have any high priority. However, there is already created an issue for it
https://gitlab.labs.nic.cz/turris/foris-controller/issues/70 and it means that we won’t forget about it.

We have been able to reproduce it, thank you for reporting it to us. This is related to kernel stuff. Unfortunately, we will solve the reported issue with a low priority. I’m going to create an issue in our Gitlab, where it can be tracked.


#37

Well i thought, that on first eth0 is linked LAN0-LAN3 and second eth2 is linked LAN4 (eth1 linked to WAN).

Its not like that?


#38

Could not get odhcpd to listen on port 67 for ipv4 dhcp queries (dnsmasq disabled/stopped/removed). Lodged as gitlab issue #376.


sorted - besides setting maindhcp to 1 it requires to set also dhcpv4 to server in the iface dhcp section

config dhcp 'iface'
        option dhcpv4 'server'

#39

Excellent job!
Updated from tos 4 alpha5 yesterday without any issues

Mox A and D module


#40

That is default setup in Turris OS 3.x. You could change that in Luci interface. In Turris 1.x are all lans connected trough eth0 and eth1 (this time connected to switch) is not used to connect to switch. Eth2 is wan.