Turris OS 4.0.3 is released into HBT!

Dear Turris users,

We would like to inform you that Turris OS 4.0.3 was released into HBT (Testing) branch. There are a few changes, which you can find. Most likely backport security fixes for libvpx and updated kernel to the latest version 4.14.158.

Full release notes for this release:
• Merry Christmas!
• kernel: updated to version 4.14.158
• foris-controller-subordinates-module: limit custom name length
• tvheadend: ensure the first setup works
• libvpx: fix CVE-2019-9232, CVE-2019-9325, CVE-2019-9371, CVE-2019-9433

When you want to try this release, you need to use the following command: switch-branch hbt in the command-line interface.

If you experience any bugs, please let us know.

We wish you a Merry Christmas!
Your Turris Team


Tried and I can confirm that also on this version I have the same error trying to install sentinel-nikola and minipot. Problem already presented on 4.0.1 and 4.0.2 in the branch hbs and hbk, for the others I have not tried. The error I reported on another thread Collaborative firewall on Turris OS 4.x.x. I don’t know if it works in the end, but I don’t think so.

MOX .5GB, WiFi, simple config, SFSG

A few words about “Christmas package” is here


Another RC is out!


  • Initial experimental support for Turris 1.x with booting from microSD card

Some of you were asking if Turris OS 4.x will be available for Turris 1.0 and Turris 1.1 routers. Those routers were given mostly to Czech people during the research project and we would like to announce experimental support in this release if you are booting from microSD card using BTRFS that you can try it! We hope you will enjoy it and if anything appears, please discuss it in the separate thread, which will be created.


How to have and configure your router from scratch to Turris OS 4.x on Turris 1.x routers?
You need to do five things. First, at all, you need to download medkit from HBS branch and you can check checksum. Then, you will import it to the factory, rollback to factory snapshot and reboot your router.

wget https://repo.turris.cz/hbs/medkit/turris1x-medkit-latest.tar.gz
schnapps import -f turris1x-medkit-*.tar.gz
schnapps rollback factory

Mox hang after restart.

Another RC of Turris OS 4.0.3 has been just released to you.


Hi @Pepe , is there a chance to include also the newest version of Nextcloud (17.0.2) ?


I’ll take a look, but it won’t make it in Turris OS 4.0.3, which is currently in RC.

Thanks everyone who tested this release. We released it for everyone.