Turris OS 4.0.2 is released into HBT - Testing branch

There is something wrong happening with package ddns-scripts. You might want to wait a little bit until it timeout and the update will proceed further.

For more details you can take a look at this issue:

In 4.0.2 HBT I can’t install the MOX netboot package from Foris on my Turris Omnia. It only tries to install 1 package (foris-subordinates-plugin), but I get this error:

Nov 24 11:10:24 turris updater[11374]: planner.lua:479 (Globals): Request not satisfied to install package: foris-subordinates-plugin

Is there a way to install it from LuCI? are these the packages I need?
foris-controller-netboot-module
foris-controller-netboot-module-src
turris-netboot-data
turris-netboot-tools

or any additional software needed?

Thanks for letting us know. I’m able to reproduce it, and we are working on it. Should be solved in the upcoming RC version.

hello there. TurrisOS 4.0.2 37fbc9f / LuCI branch (git-19.326.57843-b4ab367) mox classic

if i want to install software in luci, the sofware update list is showing this :
Downloading https://repo.turris.cz/hbk/mox/packages/core/Packages.gz
*** Failed to download the package list from https://repo.turris.cz/hbk/mox/packages/core/Packages.gz

Downloading https://repo.turris.cz/hbk/mox/packages/base/Packages.gz
*** Failed to download the package list from https://repo.turris.cz/hbk/mox/packages/base/Packages.gz

Downloading https://repo.turris.cz/hbk/mox/packages/cesnet/Packages.gz
*** Failed to download the package list from https://repo.turris.cz/hbk/mox/packages/cesnet/Packages.gz

and
Collected errors:

is this maybe a wget issue?

best, dikke

This should resolve the issue for you, DIKKEHENK:

1 Like

In HBK branch, it should be already solved. It was the same issue as @p4p4 mentioned. For more details, you can take a look at this pull request:

Thanks for letting us know about that!

1 Like

We have just released another RC version of Turris OS 4.0.2.

The changelog between RC3 and RC2:

  • kernel: updated to version 4.14.155
  • unbound: updated to version 1.9.5, fix CVE-2019-18934
  • php7: updated to version 7.2.25, fix CVE-2019-11043, CVE-2019-11042
  • bind: updated to version 9.11.13, fix CVE-2019-6477
  • libiconv: updated to version 1.16
  • pimbd: updated to version 2018-06-19

Known bugs list is now empty.

2 Likes

This new RC broke my wifi (Turris Omnia). Resetting the wifi in Foris, and re-entering the config (and forget network and re-enter details in windows), doesn’t help. When I try to connect to the wifi, router crashes and reboots.

Using the built-in wifi adapter on my gigabyte x470 gaming 7 (intel ac 9260).
After reboot, this was the only possible related error I could find:

Nov 27 13:25:04 omnia procd: Instance umdns::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

edit: nvm, after rolling back, I see the same error in log. But the router doesn’t crash and reboot when trying to connect to the wifi.

MOX classic, .5 GB, WiFi. Updated to 4.0.2 RC3; reboot took extreemly long, after about 10 min powered down, then OK.

V reForisu nejdou otevírat podnabídky. Objeví se prázdná stránka a zmizí i menu. Vyrovnávací paměť prohlížeče je vyčištěná.

Turris Omnia WiFi updated from 4.0.2 RC2 to 4.0.2 RC3 and caught in a reboot loop after the update installed and asked for a reboot. Rolled back to RC2.

Update:
tried something else: rolled back to 4.0.1 before HBT, disabled/uninstalled DDNS-scripts and did “switch-branch hbt” again to 4.0.2 RC3. Update worked and asked for reboot, but then again a reboot loop… rolled back to working 4.0.2 RC2

Turris Omnia update and reboot from rc2 to rc3. After a while it got stuck in a reboot loop. Rolled back to RC2.
BTW: Update took longer than usual.

Omnia updated and rebooted last night; woke up this morning without routing/network access (don’t have any WiFi cards installed) and a reboot resolved the issue.

I found what is causing the reboot loop for me in 4.0.2 RC3:

  • I managed to successfully update my Turris Omnia WiFi from RC2 to RC3 by resetting WiFi settings in Foris, keeping WiFi disabled and then rebooting
  • With disabled/reset Wifi the 4.0.2 RC3 update works and also no reboot loop anymore
  • as soon as I reconfigure WiFi manually again and reboot, the reboot loop is there again as soon as WiFi goes up
  • so there seems to be an issue with the WiFi driver in RC3??

Thank you for reporting problems with reboots. Issue can be tracked here https://gitlab.labs.nic.cz/turris/turris-build/issues/97.

1 Like

hello there. My Mox classic TurrisOS 4.0.2 5c18e8f / LuCI branch (git-19.331.32417-bb0a468) is on switch-branch hbt . about 6 days ago ( 27 -11) it stopped doing the daily updates.
Then i did switch-branch hbt again, and it gave this update

News announcements

• Based on the latest OpenWrt 18.06.5
• added missing hardening package list
etc etc

after that update, it stopped again updating. When i do “switch-branch hbt’” again, it is loading the same update as above.
Not sure if this is supposed to act like this?

There was no release to hbt branch since 27.11. and release before that was 18.11. There was just no update to apply.

Switching branch cases full router reinstall so that is why it sent you news announcement. It wasn’t because router was updated. It was because switch-branch runs pkgupdate --reinstall-all.

1 Like

ah ok, that explains. thank you.

Kdy bude verze 4.0.2 vydána? Je první, která umí propojit Omnii a MOX přes Foris a rád bych začal používat Netboot.

When is it going to be released? Well when we resolve problems present in release like reboots when client connects to Wi-Fi. Trust me we would be happy if it would be already out but we can’t release version with such fatal problem to stable.

4 Likes