Turris OS 3.9.2 is out!

Dear Turris users,

we just released Turris OS 3.9.2! What it contains? Mostly bunch of bugfixes and security fixes, so this should be quite boring release.

  • musl & busybox: use stronger password hash by default
  • kernel: update to the newer version
  • netmetr: fix configuration reset
  • updater: various small fixes
  • openssl, libtiff, socat, rsync, coreutils, php, irssi: security updates
  • tvheadend, haas: update to the latest version
  • knot-resolver & unbound: fixes in local domains
  • suricata: fix startup issue on some routers, performance tweaks

Happy routing,

Team Turris


no problems…thxs. Now trying to get this haas thing working.
Best, Dikke

HaaS not working. I not seeing device on https://haas.nic.cz/devices/. Can someone help me?

why are listen ports reconfigured? AGAIN?

please dont make duplicated posts or thread, when I already responded to you here:

For English speakers:
Check if you have HaaS token in file /etc/config/haas.
If you don’t have it then please go to https://haas.nic.cz/ log there, add new device, name it and you should see token. Copy it and paste it to option token in file /etc/config/haas

Also HaaS doesn’t record sessions and you can find it in our Errata, which we updated a few days ago.
We’re really sorry for that and I’ll let you know, when it will work.

sadly this update broke my router. The Turris Omnia couldn’t now my lxc container and the DHCP funktion isn’t working anymore can you help me please? Thanks

I don’t understand whole situation.

You’ve stated “Pokud chcete používat HaaS s vaším Turris zařízením, pouze povolte tuto možnost ve vašem routeru. Vše bude fungovat automaticky a budete se moci přihlásit se stejným loginem jako pro Turris.” (rough translation: If you want to use HaaS with your Turris device, only allow this possibility in your router. All will function automatically and you’ll be able to log in with the same login as with Turris).

I thing you mean SSH Honeypot in Updater (Forris) section, which I selected.

OK - Done. But, what I do see, is:

Můj Honeypot -> My účet -> Uživatel: xxxx
Moje zařízení
Zařízení Sezení Akce
Turris with ID 2312 0

i.e. nothing :frowning:

(rough translation:
My Honeypot -> My account -> user: xxxx
My device
Device Session Action
Turris with ID 2312 0 )

What does it mean?

1 Like

it seems you edited some file, which is replaced on every update of some package.
Can I know which file you edited?

If you edited /etc/lighttpd/conf.d/ssl-enable.conf then it’s bad… :confused:
See reply here: Turris OS v.3.8 - changed ports for lighttpd

I can’t find the source of this quote.
Where it is? Can you tell me what you mean that you dont understand this whole situation?

You should see device (in this case it’s Turris) on HaaS website. That’s ok.
But there are no records. We know about it, that’s why it is listed in Errata and I even post it to a few threads. It means that you don’t need to do anything else. It’s issue on our side and we’re working on it.
@maja0027 asked why he doesn’t see device on HaaS. If you don’t see device on HaaS that’s a bug.

Please, can you send us diagnostics to our email tech.support(at)turris(dot)cz? We’ll help you.

Guys, please don’t create OT posts or duplicated posts.

@Pepe Thanks here is my diagnostic:

*** Link was removed by moderator *** (diagnostics contains sensitive information)
sadly my Msata also doasn’t mount

Please remove your diagnostics from magentacloud.de, because it contains important and sensitive data.
And send them by email to this address tech.support(at)turris.cz

thanks Pepe maybe it is just me but i culdn’t send an email to support(at)turris.cz
so i send it to info(at)turris.cz is that also the right adress?

I think you miss there tech., but info is also good!

thanks my mistake :sweat_smile:

Dear Pepe, I lost about one hour trying to find what I quoted, to no avail :frowning: and I don’t want to loose any more :frowning: Sorry I didn’t quote it properly (by means this forum offers). I do hope that you’ll take it as matter of fact that I read it and took effort to translate it for non-czech readers :wink:

As to what I don’t understand is that you state that all we need is to allow this option and all will be OK, automatically. What I did, but I don’t see anything on HaaS site regarding my Turris Omnia. No sessions.

I understand that there are problems enacting this new feature (functionality), but please don’t say “all willl function automatically” when in reality it is not so.

Sorry, I was blind. It is on HaaS site, in Proxy part, as

“Installation on Turris and Turris Omnia
If you want to use HaaS with your Turris, just enable it in your router. Everything else will work automatically and you will be able to use the same login as for your Turris.”

My translation is little bit different :wink:

It was not you, which is my biggest error. I apologize for improper assigning this quote to you. But the rest of my note remains - no data in My Honneypot part of site: “No sessions in specified interval. (01/01/2018 - 17/01/2018)”.

Sorry again.

Even after update to OS 3.9.2 Haas still doesn’t work. Since 15th December I have no detected attack to my Omnia…

thank you for finding it. I passed this information to the maintainer of HaaS website and we will change it.
//EDIT: Now it should be more clear.

@Radovan_Haban Unfortunately HaaS still doesn’t work in this release.
We’re working on it. I’ll let you know, when it will work.

I think I saw someone else reporting it on the forum: the web GUI for connection test is stuck (“Loading…”), but it works OK from command-line.

Haas and SSH hoynepot 3.9.1 versus 3.9.2

In version 3.9.1 after uninstalling SSH Honeypot in Foris, haas-proxy and open port 22 disappeared.

In the version 3.9.2 I mean unfortunately does not work. After uninstalling SSH Honeypot remains both the Haas-proxy and the related port 22.

Haas-proxy must be manually uninstall

Obviously, this was a temporary problem when the Foris Updater responded slowly and incorrectly. (When I rushed to the steps impatiently)

1 Like