Turris OS 3.6 made ucollect/firewall log unstable

Ever since my Omnia updated to 3.6 my ucollect is not stable, I had to turn it off and on again several times for it to kick in again, but firewall logging is offline permanently. I’m starting to think automatic updates are not such a great idea considering every update breaks something. :frowning:


On my Omnia, ucollect data are send correctly, firewall logs are missing for last few days.
On older Turris (1.0) everything seems to work correctly.

Similar problems also here.

Omnia is not sending data since 2017-01-09 which is even before 3.6 update. Yesterday I manage to make updates workign again after some troubles but data connection for both uCollect and firewall is still off.

So far no luck to fix it.

My Omnia stops sending data exactly when there was a dhparam package update on 11.3.2017 at 3:30 (to version 2.0).

I have tried to turn uCollect off and on again in Foris and I have just received an e-mail from Omnia. It reads several messages like:

ucollect-badconf/postrm: /usr/lib/opkg/info//ucollect-badconf.postrm: line 2: /etc/init.d/ucollect: not found

It seems that ucollect is uninstalled? At least the init script is missing.

Ahhh… It seems that after OS update to 3.6 (9.3.2017 17:40) data collecting become unstable. But after the dhparam package update it stops completely.

To reenable uCollect I unchecked everything under Data Collection, after that I received email about packages uninstalled and couple ucollect errors about missing ucollect. Then I reneabled it without enabling any emulated services which sent another email about packages being installed (this time without errors) and it works except for firewall.

I can fix firewall with

mkdir /etc/crontabs <- not sure if necessary, but apparently it may be needed by cron in 3.6

However Firewall will not stay enabled after reboot. So had to add line into System > Startup > Local Startup

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
exit 0

And now it all works through reboots


I had the same problem and fixed it using the following commands in terminal - see https://forum.test.turris.cz/t/vypadky-firewallu-a-ucollect/2377/21:
mkdir /etc/crontabs/
/etc/init.d/cron restart

Hello guys. Same issue here…