Turris OS 3.11 in RC!

release

#22

Overview i it does not provide information about used ports.
Please return Statistics.


Opinions about new graphs for Pakon
#23

Hello,

I have a question, do I have to reverse the changes to the DNS over TLS that we have made from this post in the forum:


https://pastebin.com/9S8ueB3a

The announcement says:

-knot-resolver: support forwarding and DNS over TLS for predefined servers

where the “predefined” makes me thoughtful.

Thanks for the good work continues, the Omnia runs perfectly well


#25

You can probably still continue using it as is, you should revert that if you decide to go the Foris way.

Predefined means that currently you can’t easily enter any server you want, you can just choose from few preselected options, some of them supporting DNS over TLS.


#26

Well reverting that and using the new official way would bring you back to the official&supported&tested system, which is probably good. The feature should work out-of-the-box now.

FYI, cloudflare’s DNS (1.1.1.1) with TLS support is on the list as well. We just picked a few well-known public servers as we guessed it may suit most people.

Using a custom server is possible, but not user-friendly - it means creating a custom config file.


#27

The next RC version has just been released.


#28

Perhaps it’s nice to mention the upgrade to Nextcloud 14.
I was puzzled why my desktop client didn’t synchronize anymore.
It all works, but still a mention would be nice.


#29

8 posts were split to a new topic: DNS over TLS in 3.11 feedback


#30

Today RC version - ucollect working


#37

Is ucollect activity fully functional?

root@turris:~# ucollect
INFO:  Initializing emergency signal handlers
INFO:  Creating a main loop
INFO:  Creating uplink
INFO:  Initializing PCAP (in) on eth2
INFO:  Initializing PCAP (out) on eth2
WARN:  Ignoring config section 'fakes' of unknown type 'fakes'
ERROR: No uplink configuration found
INFO:  Closing both PCAPs on eth2
DIE:   No configuration available
Aborted

Turris 1.0 RC3.11 from 31.10.


#38

Sorry, I was looking for article about Sentinel, but I can’t found it.
Can you help me?


#39

A little bit out of topic, but I just want to tell a big thank you to all the members of the Turris team for their hard work. I really appreciate to have regular updates for this crucial part of my home LAN that is my TO. Since I got it, it runs flawlessly and I never had any problems with it, including for updates.

Just want to share that. Keep the good work guys! :+1:


#40

I agree, agree, agree …


#42

Agree, ucollect online again, good work.


#43

Thanks guys :heart_eyes:
We really appreciate some positive feedback!


#44

I was trying to reply to his thread DNS over TLS in 3.11 feedback but it lacks a reply button albeit there is no indication of the thread being locked/closed.

Anyway, with the new DoT code and DNS settings now split in various (4) places it begs the question of how the various DNS settings are interacting with each other and which one takes precedence over which:

  1. “/etc/config/network”

    config interface ‘wan’
    option dns
    option delegate
    option peerdns

  2. “/etc/resolver/dns_server/*.config”

  3. dns_server config section + option forward_upstream in /etc/config/resolver

  4. backend (daemon) settings in “/etc/config/resolver”

    config resolver ‘unbound_includes’
    list include_path


Knot resolver can't handle CNAME on root level?
#45

Majordomo disappeared from LUCI > Statistics menu. Tried uncheck and check again the item in Foris > Updater > Majordomo. Foris is unable to install Majordomo. Still able to install manually via LUCI > System > Software


#46

Samba4, testing, default settings, copying turris to windows 10, cpu 100%. Why?
Has anyone tried?

EDIT:
If I have by Maxmilian_Picmaus setting, speed is of 6 MB / s, CPU load is 12%. Tested on a file of 1.45GB, Turris to Win10.


#47

No problems with this RC so far except that I cannot seem to find the correct combination of configs to point the DNS to an external Pi-Hole. As n8v8r has pointed out above, there are so many possible DNS config areas but no clear indication at all of how to perform what should be a very simple DNS change!

Unlike many on this forum, I do not have advanced software skills but I would hope that this would not be necessary for what on any other router is a matter of changing an IP Address!!

Any help from one of the many TO experts would be appreciated.


#48

->

It thus would require to edit config file(s) via ssh. Since this a feedback thread you may want to open a separate thread instead, perhaps also first perusing what is already available on the forum about the subject (search pi-hole).


#49

Thank you for your rather unhelpful and supercilious response. Contrary to your assumption, I have already searched extensively about implementing Pi-Hole and had noted the difficulties involved.

My question within this RC thread was to raise awareness that it was still very difficult (for normal mortals at least) to change the DNS settings and that this problem could possibly be addressed within the RC stage.

I was not in any case aware that you had a moderator position on this forum!