Turris OS 3.11.4 is released!

release

#44

I need to take back this statement. There seems to be a (new?) bug in LED configuration - with every restart of the router it is reset to
/etc/config/system

config led
	option name 'Auto-configuration for PCI1'
	option sysfs 'omnia-led:pci1'
	option default '0'
	option trigger 'none'

config led
	option name 'Auto-configuration for PCI2'
	option sysfs 'omnia-led:pci2'
	option default '1'
	option trigger 'netdev'
	option dev 'wlan1'
	option mode 'link tx rx'

config led
	option name 'Auto-configuration for PCI3'
	option sysfs 'omnia-led:pci3'
	option default '1'
	option trigger 'netdev'
	option dev 'wlan0'
	option mode 'link tx rx'

I think this is default configuration of TO with 2,4/5GHz-card in mPCIe-slot 2 and a 2,4GHz-card in mPCIe-slot 3, right?
I changed this configuration because of bad position for 2,4GHz-card (see other thread for this) and now have default TO 2,4/5GHz-Card running in mPCIe-slot 1 and a WLE1216V5-20 in mPCIe-slot 2 with the following configuration:

config led
	option name 'Auto-configuration for PCI1'
	option sysfs 'omnia-led:pci1'
	option default '1'
	option trigger 'phy0tpt'

config led
	option name 'Auto-configuration for PCI2'
	option sysfs 'omnia-led:pci2'
	option default '1'
	option trigger 'phy1tpt'

config led
	option name 'Auto-configuration for PCI3'
	option sysfs 'omnia-led:pci3'
	option default '1'
	option trigger 'none'

Edit: my fault, this is not bug, but intended feature (see posts below).
Disabling LED-autoconfig-script solved my issue.


#47

Rename as follows:
option name 'Auto-configuration for PCI2'
on
option name 'LED2'

and

option name 'Auto-configuration for PCI3'
on
option name 'LED3'

or

run command via ssh:
/etc/init.d/led_autoconfig disable


#48

My 5ghz networks are down (normal and guest) since the update. 2,4ghz works luckily.
I have not modified the router in any way.

Any ideas? I already rebooted several times and disabled and enabled the 5ghz interface.


#49

Did you found some solution (or is it already fixed)? I just rebooted my Omnia after updating TOS and in my case all fine. If you still have this issue, let me know what/where to check, maybe we can find some difference/fix.


#50

Not yet, any help is appreciated. My 5GHZ network is just not visible but does seem enabled in Luci.


#51

Sorry for the late answer. I havent made any changes to the kresd. In fact I am trying to limit changes to bare minimum (e.g. reserving certain IP addresses for devices in DHCP). Thats why I am surprised to see that the updates are causing issues…


#52

Does anyone else have issue with data collection after installation of this release?

my TO says: Firewall logs: unknown status

thank you


#53

Had to factory reset and reconfigure and the 5GHZ network works again.

Restoring backup caused the problem again.


#54