Turris OS 3.11.10 is released!

Od včerejší aktualizace žádný restart.

Thanks, and you have already answered the problem I also experienced yesterday with 3.11.9: the reboot loop. I’ll upgrade then.

After upgrade, WiFi not connect to internet…

Dear all,
I have issue with wifi on 3.11.9 as well. Initially, affected was single-band module, then i added SSD so shifted modules and now dual-band card has issue. Couldn’t be kernel bug in access to PCIe lanes instead of wifi module?

Takže to řeší Reboot loop when starting ??

Ano, řeší. Tohle bylo v nejnovějším releasu Turris OS 3.11.10 opraveno.

1 Like

omnia aktualizovana na 3.11.10 a zatim bez vyse zminenych chyb :blush:

good job Turris Team

1 Like

Zdravím, běžím na víceméně čerstvém turrisu 1.x s 3.11.10 na btrfs (factory reset minulý týden, nic extra neinstalované) a mám problém s upnp - dle všeho vypadá, že funguje, ale v Luci se mi nezobrazují aktivní redirecty, pouze hláška ‘There are no active redirects.’
Tušíte kde by mohl být problém? Co jsem koukal, tak na turrisu není vytvořený lease file - /var/run/miniupnpd.leases
Zkoušel jsem ho i manuálně vytvořit, pro jistotu mu dal 777 práva, ale na výsledku to nic nezměnilo.

My MOX no longer netboots now I have upgraded to 3.11.10 - any pointers?

Pravděpodobně nemáte veřejnou IP adresu a jste za NATem ISP. Viz man miniupnp od řádku 10 (round 10).

You probably don’t have a public IP address. And you are behind ISP NAT.

Jak píšu, UPNP reálně funguje, jak torrent tak plex mají namapované porty a jsou z venčí dostupné. Veřejnou (dokonce i pevnou) IP samozřejmě mám, až takový noob nejsem :slight_smile: Jedná se tedy nejspíš jen o problém se zobrazením… Dříve mi to určitě fungovalo.

//EDIT:
Ještě možná doplním, že vnitřní síť mi nejede na standardní 192.168.0.0 síti, ale na 10.0.0.0 síti. Někde jsem snad zahlédl info o problémech s upnp, pokud nejede na tom základu…

Zkusil bych se podívat do spouštěcím skriptem vytvořeného konfiguračního souboru v /var/etc/miniupnpd.conf jestli je tam ten váš 10.0.0.0 rozsah pro lan.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

tento soubor neexistuje… našel jsem akorát /etc/config/upnpd, ve kterém je, stejně jako na webu 0.0.0.0/0, což jestli se nepletu pokrývá všechny IP… každopádně jsem to zkusil změnit na 10.0.0.0/24 a upnp přestalo fungovat úplně :smiley: i po změně zpět už si klient IP nenamapuje :))

//EDIT:
tak vyřešeno… netuším proč, ale v tom defaultním configu bylo “enabled 0” a po té změně to přestalo jet úplně. změnou na enabled 1 se přegeneroval celý config a teď už běží i zobrazuje. To by mě zajímalo, co to bylo za bug :slight_smile:

Again: could you guys please stick to English in English section?

@topic: TO access point with 3 WiFi-cards is working, but I had to rebuild WiFi-config from scratch via luci - any direct changes via SSH lead to WiFi being not functional any more (none of my SSIDs will come up any more, rebooting doesn’t help). One then needs to reset WiFi and start from scratch in luci…

https://github.com/CZ-NIC/turris-os/commit/ad76f9252b162f42955b4cb5dea8c86992c48fd3

When will be solved mlan3 issue?

https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/278

When will be updated kernel?

Is it solved problem with delayed updates?

Of course! When the topic for releasing a new version in the Czech forum will be reintroduced.