Turris Omnia WLAN not working

Hello there,
I’m fresh new owner of Turris Omnia 2020. I put it behind the T-Mobile router, connected by cable. I basically replaced my old router by Omnia so cables are working (as old router still works).
My issue is that I cannot connect Omina to the internet. Computer connected by LAN to Omnia cannot connect to internet.
What I did:

  • Went through connection wizzard for router. LEDs shining white, can see WLAN LED shining. When I hit save on network tab (where are showing connected cable to WLAN and LAN), saving never happen. After restart router I can continue to WAN step
  • WLAN - no changes just click Save & Test. Most of the time IPV4 finished with error, from time to time I got green, but computer still cannot access internet
  • DNS - left as default, after Save and Test, got green. One or two requests are successful and I can see Google (with random search phrase), but after refresh I’m offline again
  • I tried 5x times factory reset (hold reset button til three LEDs shining). I can see the Connection wizard again. But without any progress.

Basically I do not know what could be wrong. Should I configure the Omnia as repeater?

Please any suggestions?

I solved it. Both routes has the same IPs, once I changed IP of Omnia it started work.