Turris Omnia, Wifi transfer rate (suddenly) slow and unstable

Hi,

I like to ask if someone can provide a hint, with solving a slow and unstable Wifi(2.4G). I tried to diagnose anything I know that can cause Wifi problems, even turned off the fridge :slight_smile:

My Question: Could a recent SW Update (year 2020) affect Wifi performance?

My problem:
My turris omnia Wifi(2.4G) transfer rate dropped to about 1-8 Mbps on any client device I try to use.

Also, the Wifi data transfer is unstable, for example, when I play Youtube video on Sony TV and open a website on MacBook, both TV and Mac will lose data transfer for couple of seconds. Both devices are still connected to Wifi, but the transfer rate is like 0 (zero). Even simple tasks like DNS queries fail when using Wifi.

Note: LAN/WAN is OK, the only problem is Wifi data transfer.

Some Facts:
I am using Omnia from 10/2017, didn’t made any changes in SW/HW configuration. (not even touched it :slight_smile: Currently, when doing “Ping” from clients to router, the ping response is from 200ms to 5500ms, it changes drastically with every sending ping request. Also there is about 10% packet lost. Even connecting to Foris or LuCI GUIs are problematic when using Wifi.

The clients are about 5 meters away from the router with no-walls and no-obstacles. (no changes for 4 years in this setup)

What I tried to Fix/Diagnose so far:

  • Tried to change Wifi Channel numbers (to best not-used channel)
  • Tried to change Wifi mode: Legacy / N / AC
  • Tried to change Width: 20Mhz / 40Mhz
  • Tried disable/enable WMM
  • Tried to change MTU on client devices (MacBook / Lenovo NB with Linux)
  • Tried to switch off all electric devices in home including Wifi clients, except one.

Still I get 1-8 Mbps transfer rates and instability, practically can’t use wifi for basic tasks.


WIFI: Qualcomm Atheros QCA9880 802.11bgnac (radio0)
Device: Turris Omnia
Serial number: 51539611959
Turris OS version: 3.11.21
Kernel version: 4.4.199-a890a5a94ebb621f8f1720c24d12fef1-1


Thank you for any advice. Stay safe.

1 Like

You try test WAN speed with Foris Netmetr?
You check router CPU load?
By wifi problems is recomended (I think), reset wifi in Foris menu and new setup.

Hi @JardaB

CPU load average: 0.01, 0.02, 0.00

WAN connection is OK

Thank you for the TIP with “Foris / Wifi Reset”, will try.

Then I would try to reset the wifi in Foris (beware, at the same time the wifi turns off and for setup the machine must be connected to the router by cable).

Is this a permanent condition ? If not, I’d be looking for interference.
I would check the status of antennas and cables to antennas.

I recently did a reset by mistake and the connection speed has slightly increased. Then I have experience that the length of wifi passwords has a significant effect on speed. This was demonstrated by a test on the WLAN network and wifi guest. Where password WLAN I have 40 characters and guest 8 characters :slight_smile:

I can’t give more detailed advice

Using wired connection it works flawlessly, right?

I would say that this is caused by interference in 2.4 GHz frequency and that you should use 5 GHz if possible. These days many APs are using 2.4 GHz frequency and it is almost impossible to find channel, which wouldn’t be used. You might want to check our documentation for common problems in Wi-Fi and increasing signal coverage by using Wi-Fi analyzer.

Also, keep it mind that for Wi-Fi antennas there are used diplexers and this card Qualcomm Atheros QCA9880 802.11bgnac (radio0) even you can use it for 2.4 GHz or 5 GHz, it should be used only with 5 GHz unless you changed pigtails.

2 Likes

Just to make sure: Did you try turning it off and on again?

2 Likes

not sure if this helps …

after some TOS update uci config for wireless was a bit different (hw_add vs path, type, ieeee802 stuff …and some options are autodetected since ; not mentioning some new features :slight_smile: ). So i think it might be the case. You can try to use “schnapps” to rollback to working snapshot (my favorite solution to any issue after TOS update :), with disabling the updates until you know what-where-how :slight_smile:
Or you can compare it with actual setup to see where you have differencies.

Aside, HT20/HT40 , keep the 20. 40 can be used only if you have single AP and channels are not crowded (in ht40, there are more channels at use and if side channel is not free (or fit in the range 1-5 o 7-11) it will fail back to ht20 anyway).

You can limit the distance so you are not broadcasting outside your house (i am using distance 10m). You can explicitly specify the rates you want to use (not depending on what driver default/setup is).

For “radio0”, there are also extra options:

option bursting '1'
option ff '1'
option turbo '1'

But that is for 5G not the 2,4G radio. So if you are using that radio0 on 2,4G you have to change the wiring (from chip to duplexers ; nearby each cable conector on duplexer you can find small text indicating if that is for 2,4 or 5G) as Pepe noted.

I am wondering why you are not using that second radio1 instead of radio0?

Somehow “country” is important, if not correctly set (or detected during boot) you can face some issues. So ensure you are using correct one :). I would explicitly set all driver-detected(default) values, to avoid any use of default values (just to be sure).


1 Like

@Maxmilian_Picmaus

thank you for your great reply :pray:

  • I did setup “country” option. (Foris alerted me about this. :slight_smile: Foris is great)
  • Also I thinking about making a new Wifi on “radio1”. (but no need for that at this time)

anyway Omnia is serving me well, Maybe I just have some, minor problems.

Thank You for the technical explanations/Tips.