Turris Omnia WiFi health

My laptop disconnects from the Omnia repeatedly throughout the day.

MacBook (when it’s connected):

Omnia:

Any suggestion on how I might diagnose the situation? What’s the likelihood that the Omnia’s cards are failing?

** edit **

Workstation is a 2019, 16" MacBook Pro.

can you test con wifi 2 with 20mhz bandwith? because sometimes if you have 40mhz on noisy enviroment doesnt work well

1 Like

May MBP 2012 doesn’t even see the 5ghz network.

I’ll probably solve it with upgrading to a 16“ M1 machine :joy:

i have a macbook 2012 and mac mini 2016 with last MacOS and i havent any issu with 5ghz, so is very strange. Sometimes in macos takes time to show 5ghz wifi. Maybe can be a region issue? have you changed to channel manual in a low channel like 36, 40?

My 2016 MacBook Pro, as well as my Surface Pro 3 disconnects from the Omnia 2020 that I just got recently seemingly at random in the middle of a video conference call. I am very dissapointed with this product right now, and am considering returning it altogether, unless a firmware update addressing this problem were to be issued promptly (honestly, this is an expensive piece of equipment, let’s hope it’s just an issue with the OpenWRT software that can be fixed over air)…

Fingers crossed!

I use the “auto” setting for both cards. I don’t seem to have a problem with the 5Ghz card, however.

This may be of some use to you…

Update to the latest Turris OS, switch to the raw OpenWRT, then install an configure the watchcat plugin that can take care of most of similar situations to yours (it solved the issue in my case).

Turris should, however, have watchcat configured out-of-the-box, and it doesn’t (yet).

I have replaced Omnia with controller + 3x AP.
Partialy because:
Omnia does not have good range, next room I had lot of places without coverage at all.
Roaming does not work between omnia and other APs.

So this could be the way to go for you too. Just dont forget to finaly disable wifi on omnia.

Also I want to add note:
I do not have noisy PHY environment - its a house where neigbouring wifis are not visible almost at all. and there is only one on one side.

The specifications and the datasheet indicate that the router uses the Complex WLE200N2 and Complex WLE900VX:

But my router has the Qualcomm Atheros QCA9880 and AR9287:

My unit is probably using older component than what is being used currently.

Should I consider purchasing the Complex ones? Maybe cards (which?) that support 802.11ac wave 2?

Just some hints …

If you are using 5G wifi on chanels using DFS then it might cause MacOS clients to be disconnected time to time. Aside of that, check if the wifi adapter is not powered down by power management (if that occurs and AP will send ACK and does not get response in time, it will disasociate that client - disconnect it, until it will try to reconnect).

Check this thread: Solution found for WiFi clients disconnects
There are some hints which you can try to set in “wireless” uci (option wpa_group_rekey '86400'
and option disassoc_low_ack '0' worked for me in the way that i have less messages in log related to wifi/client disconnected. If you are not having wpa_group_rekey explicitly specified, default value is used by hostapd (which is 300 if i remember well).
[OpenWrt Wiki] Wi-Fi /etc/config/wireless

If you are using 2,4 and 5g together do not use HT+ /HT- on 2,4 wifi at all, stick with the 20 (even if you use 40 it will probably fallback to 20 anyway as very probably there won’t be free side channels or you are using center channel at the edges of the channel range , so no side-channels are available). If you are having only 2,4 at use you can benefit from HT mode (if you have not so crowded area with AP). On the other hand when you are using 5G you can use VHT40/80/160 as you want.

And basically, you have DHCP lease and “wpa_group_rekey” time values. So not only AP it self might disconnect client, it also kind of ask for new lease and it might cause that client has to reconnect to AP again. If this occurs, i have like 1-5sec with no connection at all and when trying to reconnect to same AP it actually fails (… until, kresd/resolver finish the lease refresh/add lease/remove lease …), I can connect to my other APs as used-to (without any delay).

Also what i’ve notice with my work-laptop (which is usually in vpn and has own domain), that it is almost only client having such issues (other clients do not stay connect over 12h resp 24h).

For some users it helps changing from PSK2+TKIP+AES to PSK2+CCMP.
5G AP can also benefit from those settings: option bursting '1' ; option ff '1' ; option turbo '1' (but check if those applies for you, if those are compatible with your TOS/OpenWRT release ; now i do not see those options in uci/wireless docu on Openwrtwiki [OpenWrt Wiki] Wi-Fi /etc/config/wireless anymore.

My Omnia’s 5GHz wifi seems to randomly disconnect Apple devices. So I restrict Macbook Pro and iPad Pro devices to 2.4GHz only, using a different SSID … no more problems. Non-Apple devices use 5GHz with no trouble.

Thats strange. I have Ipad Pro 12,9 with M1 chip.
It should have superb capabilities of talking with access points.
In fact, its worst device. Much worse than 2,5 years old Huawei P30 Pro. Shame on apple. Shame.
So I would say that it could be related to absolute hardware crap that is Apple.
(I am using TP Link EAP 225 AP’s and they are imppresive - I dont have any disconnects, only low reception in the crappy HW (yes, I am talking about you Steve Jobs descendant) and some bugs that the device does not process repeated packets)