Turris Omnia + Turris Shield setup for ppoe (xdsl modem is in bridge mode)


I have problem with setuping Turris Shield and Turris Omnia (tried both these devices) on xdsl as ppoe connection (xdsl modem is properly setup in a bridge mode with public static IPv4 address - with disabled IPv6)

  1. Turris Shield:
    Factory reset - connected to xdsl modem - on Shield site I’ve setup only the WAN Connection (as a PPoe (with PAP/CHAP username and password o2). And on this screen I get error - IPv4 Gateway connectivity. IPv4 connectivity is OK.
    This error doesn’t change even I change DNS settings (Use/don’t use forwarding (providers dns, CZnic DNS), use/don’t use DNSSec)

Device:CZ.NIC Turris Mox Board
reForis version: 0.9.1
Turris OS version: 5.1.10
Kernel version: 4.14.222

2.Turris Omnia
Therefore I’ve tried Turris Omnia - factory reset - and during the wizzard when I setup the PPoe connection it freezed on checking connection.
Nevermind - I’ve skipped this wizzard and setup there the WAN setting for PPoe (with default LAN settings)
Ipv4 Protocol PPPoE
PAP/CHAP username,password o2
IPv6 protocol - disable IPv6

Connection test:
Ipv4 connectivity - Error
IPv4 gateway connectivity - Error

moreover in DNS setting:
use forwarder (Google or CZnic) - enable/disable DNSsec - I get everytime DNS and DNSsec Error

Device: Turris Omnia
Turris OS version: 3.11.23
Kernel version: 4.4.199-a890a5a94ebb621f8f1720c24d12fef-1

Why I get everytime connection error?

and my next guestion is: I’ve tried to setup VPN (on shield you can just enable it - create certification authority and setup UDP or TCP) I’ve tried both option bud I didn’t able to connect to my public IP over VPN.
When I did the same on Turris Omnia - I was able to connect to VPN.

Is the Shield able to use as a VPN server and work is for anybody?
Best regards

btw - dsl modem is setup properly - I’m using it together with other VPN/firewall box from another company and this setup works - I’m using it more than 1 year for VPN users.

if the xdsl modem is in bridge mode, it should not have ipv4 address.
maybe for local connections, what’s its IP and what’s your router IP?

I get the right statitc public IP address

I guess it means you get right static IPv4 address on your omnia, is that correct?

is it just the “IPv4 gateway connectivity” that fails? Does your internet connection work properly?

It has nothing to do with DNS maybe the provider doesn’t allow you to contact the gateway.

Have you tried with the “Use forwarding” with “Use your provider’s DNS resolver” ?

yes, it should be able to work as the VPN server. But first let’s get your connection work properly.