Turris Omnia: reForis / Network Settings / WiFi - "An error occurred while fetching data."


I have the latest version of OS on the First generation Turris Omnia - for days prior this incident I was able to get into the WiFi Network Settings in reForis and I was able to click on the Reset WiFi Settings button. Suddenly I can no longer access this on any of my connected devices, iPhone, MacBook, iMac / Safari / Chrome - nothing works! Connected via WiFi to the router or via ethernet cable also makes no difference. I had not touched anything on the router during the week prior me finding out it’s not working. I tried to rollback few days back - nothing helped.

What is it and what can I do to fix it please?

Thank you.

Is there anything in logs? Is it repeatable, I mean if it shows same error when you click wi-fi settings?

Hi! Yes, it shows every time I click on the WiFi settings, on any device and browser, as well as after device reboot and via wifi and cable.

I have not checked the logs yet.

I searched the forum, similar issue popped up for someone in 2022 in a different spot in the reForis - not finding solutions there.

It’s strange it’s asking me to enable wifi - when it’s enabled and running.

Not sure, but I’ve had typos in my config files and seen stuff like this. Not sure if you’re up to digging around after logging in with ssh.

I do see those and they seem to work as I did roll back from one. :slight_smile:

I would be up to some digging around @jklaas but I have no idea where and what to look for. I don’t use ssh to configure the router, only Luci and reForis only for visual check or rolling back or the internet speed info.

Sometimes, when you dont know the answer, please avoid such statements. This has nothing to do with eMMC. From the screenshot, it is obvious that it is related to reForis frontend UI, nothing else is going on.
There could be typos or some invalid values which reForis does not accept for Wi-Fi, if it was configured by hand or in LuCI as correctly pointed out by @jklaas. What is enough is to basically reach the Technical support department as they know how to proceed with issues like these. You can see more details in the browser’s developer console. If you don’t know how or what you should be looking in the developer console, here search button might help. :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.