Turris Omnia Dead?

After not using my Turris for half a year I rested him via the reset button mode 3, based on 1. On the fresh omnia I configured this things:

  • PPoE Settings for my ISP
  • Updated to newest software
  • Enabled wifi with both radios
  • Enabled about 10 Graphs/Collectd in Luci

After 5 hours of operation the Internet suddenly stopped working. At the Turris the LEDs flashed the following pattern in a loop: 1x B long white followed by 5 x A short red. When this did not stop after 15 minutes, I disconnected it from the power, waited and reconnected it. Unfortunately the previously mentioned LED pattern started again immediately. I tried to reset the Turris again, unfortunately it does not respond to the reset button. The LED pattern flashes exactly the same whether I press reset or not.

Meanwhile, I’ve been trying:

  • Using the power cable from a colleague who also has a Turris.
  • Connect with a serial cable as described in the omnia youtube video. Unfortunately minicom does not display anything.
  • Booting the turris over serial cable, based on 2. sendbeacon returns 0 after I connect the power. The kwboot asks immediately for a reboot. After the reboot everything is like before (blinking leds), the command never exit.
  • Removing the SFP and the two wifi cards. Still 1 x white, 5 x red.

Now I have no more ideas. Do you have any?

Minicom Settings:
turris_serial_settings

Serial Boot:

turris

Output from the serial console might be crucial for debugging.

Could be an indication that RX and TX of the UART cable are not connected to the correct pins on the board https://docs.turris.cz/hw/serial/#turris-omnia, cable TX <-> RX board pin and cable RX <->TX board pin.

I checked the pins they are the same as in the picture.

I have now tried several times to turn the power off and on. Once a question mark appeared in the minicom console, the status in the lower right corner remained on offline

Did you try switching TX | RX anyway? Also the documentation mentions screen /dev/ttyUSB0 115200 for a UNIX client?

If neither works the serial transmission issue could probably be caused by:

  • serial cable
  • serial port on the client
  • O being dead indeed

Last resort perhaps to contact the manufacturer through their support channel or claim warranty (if still covered) from the vendor.

i would try to download medikit package https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz
and use option 4 LEDs: Re-flash router from flash drive , re-flash and reboot took a bit longer. So give it some time. Once flashed , let “pkgupdate” do the rest (give it more time to finish)

ad_red_led: When LEDs turn red, it means that some highly sensitive operation is in process and data may be corrupted if it is interupted. Try not to reset router during the proccess or you might end up with corrupted filesystem. That one can be fixed using mode 4 but with complete data loss.

ad_time(s): some time ago i had 20-40mins long reboot when i did rollback to previous snapshot containing previous TOS version. Not sure now, but one version of TOS (3.8. to 3.9 )caused also cyclic-unwanted reboots and bootup time increased significantly (later it was fixed in next update, so 3.11. should be fine regarding this) i am just mentioning it, maybe it was your case…

1 Like

Thank you for your answers.

@mrs.crox: Yes I switched them anyway. Unfortunately it is exactly the same with screen. I have now ordered a different serial cable to avoid a problem with the current cable.

@Maxmilian_Picmaus: Unfortunately my Turris does not respond to the reset button. Only the above mentioned blinking pattern is coming.

Is there nowhere a list of what which blink pattern means? Like the beep codes on computers.

Does not seem documented. The pattern could probably be triggered two-fold:

  1. in pre-boot state by the firmware of the ARM Microcontroller (e.g. for the CZ11NIC20 board that would seem to be a STM32F030R8T6TR chip)
  2. in OS booted state by LED device tree bindings https://www.spinics.net/lists/linux-leds/msg11539.html and userland control settings https://www.kernel.org/doc/Documentation/leds/

Hopefully that will work and provide insight

In the meantime the second serial cable has arrived. Unfortunately the Turris behaved exactly the same, zero serial output.

Because I didn’t know anything else I just tried random stuff. Then I noticed something. When I install an M-Sata SSD the kwboot command suddenly gives an output! Both for the uboot and for the resuce-image. What could that mean?

Unfortunately, I do not understand what that means.