Turris omnia can't connect ISP with PPPoE

Hello. I can’t connect to internet provider with PPPoE. I flashed last medkit, but it not helped. Phisically port fine, I tried DHCP connection on this port, and it works. Providers line also fine, raspberry pi and notebook can connect internet with this line. I cannot find out what’s the problem. Is there some tool like pppoeconf or something similar to debug connection ?

the system log prints related messages as start point for debugging, e.g. from the ssh cli logread | grep ppp.

Advanced verbosity can be achieved with enabling the debug flag in /etc/ppp/options

Thank you for answer. I enabled debug flag. Seems router can’t recieve PADO packets, like link is not connected. I checked connecton. What else I should check ?

Would not reckon this is an issue of not being able to receive PADO packets but rather the packets going upstream not being received by the ISP in the first place and subsequent no PADO packets returned.

What is the setup for upstream connectivity, e.g.

  • ISP -> modem > TO?
  • which modem?
  • does the ISP require VLAN ID tagging?

What is the output from (redact/obfuscate whatever you feel necessary):

  • ifstatus wan (ipv4)
  • ifstatus wan_6 (ipv6 if applciable)
  • ifstatus wan_6_4 (ds-lite if applicable)

I contacted my ISP support once again. Technician came and we tried to plug router beside line, that come to apartment. Connection established only with 8-wired cable. Technitian upgraded line to apartment, and now connection works.
Some glitches are still present. Sometimes router not establish connection like before, despite wan led is flasing.

But mostly connection successful

If option foce link is enabled connection more often succeed. Glitches not big problem.