Turris Omnia 2020: SLOW / WEAK / DISCONNECTin'

Hey!

I have a Turris Omnia 2020.
I replaced the original TP link router with the Turris and the previously trouble free network started to be absolutely awful.

  • disconnecting devices
  • very weak signal in the house
  • no signal in places where 30 % was before

Any advice? I thought this hardware was top notch but so far I’m very disappointed.
Thanks in advance for any tips.

I found this for example, but as I am no expert, at most a very advanced user,
I preferred to go here first.
https://feeding.cloud.geek.nz/posts/fixing-turris-omnia-wifi-quality/

I tried the basic wifi combinations - 2.4ghz, 5ghz / 20mhz / 40mhz = same results
Currently : 2.4ghz, 20Mhz

I have diagnostics log if somebody seems it useful, just dont want to share straight away.

Maybe your wifi coverage has changed. If you live in rural area try to check with WifiAnalyzer app channel coverage.

Thanks for your reply, but no :slight_smile:

  1. The problem occurred immediately after reconnection
  2. the problem disappears when I use the TP link router
  3. I have internet via fiber optic cable, wifi is only home network
    So thats just Omnia issue.

Hello.
Can you please open the device (use the PH1 or PH2 screwdriver) and take a picture of the pigtails connecting the WiFi cards with the duplexers?

@hagrid
Definitely, thanks for quick reply, images below:

Thank you very much. So, it seems the pigtails are connected in order (big card to 5.6GHz path and small card to 2.4GHz path).

Can you verify you have not mismatched the configuration? Like, the big card is set to broadcast on 5GHz band and not on 2.4GHz band?

@hagrid
If you mean the Wifi options in the settings in the reTurris environment:
Wifi 1 (5ghz + 2Ghz)
Wifi 2 (2ghz)
I tried all combinations.

(Turn off turn on 5ghz, just 5ghz, just 2ghz on 1 or 2 or in parallel, as well as I wrote, I’ve also tried the alternative bands 20mhz/40mhz)

I left the current setting at Wifi 1 : 2.4ghz because I found somewhere that the transmitter on Wifi 1 should be stronger (but no change.)

One more thing… have you set the correct timezone?

Can you paste here the output of uci show wireless (do not forget to redact the keys)

@hagrid
Due to LuCI & reForris timezone and time match.

uci show wireless

wireless.radio0=wifi-device
wireless.radio0.type=‘mac80211’
wireless.radio0.macaddr=‘macadresswashere’
wireless.radio0.country=‘CZ’
wireless.radio0.channel=‘auto’
wireless.radio0.disabled=‘0’
wireless.radio0.hwmode=‘11g’
wireless.radio0.htmode=‘HT20’
wireless.default_radio0=wifi-iface
wireless.default_radio0.device=‘radio0’
wireless.default_radio0.network=‘lan’
wireless.default_radio0.mode=‘ap’
wireless.default_radio0.hidden=‘0’
wireless.default_radio0.encryption=‘psk2+ccmp’
wireless.default_radio0.wpa_group_rekey=‘86400’
wireless.default_radio0.disabled=‘0’
wireless.default_radio0.ssid=‘namewashere’
wireless.default_radio0.key=‘passwashere’
wireless.radio1=wifi-device
wireless.radio1.type=‘mac80211’
wireless.radio1.channel=‘11’
wireless.radio1.hwmode=‘11g’
wireless.radio1.macaddr=‘macadresswashere’
wireless.radio1.htmode=‘HT20’
wireless.radio1.country=‘CZ’
wireless.radio1.disabled=‘1’
wireless.default_radio1=wifi-iface
wireless.default_radio1.device=‘radio1’
wireless.default_radio1.network=‘lan’
wireless.default_radio1.mode=‘ap’
wireless.default_radio1.ssid=‘namewashere’
wireless.default_radio1.hidden=‘0’
wireless.default_radio1.encryption=‘psk2+ccmp’
wireless.default_radio1.wpa_group_rekey=‘86400’
wireless.default_radio1.key=‘passwashere’
wireless.default_radio1.disabled=‘1’
wireless.guest_iface_0=wifi-iface
wireless.guest_iface_0.disabled=‘1’
wireless.guest_iface_0.device=‘radio0’
wireless.guest_iface_1=wifi-iface
wireless.guest_iface_1.disabled=‘1’
wireless.guest_iface_1.device=‘radio1’

@hagrid was it helpful?

when I configured my omnia, I somewhere read NOT to run both cards ad 2.4GHz because they may interfere with each other.

You should be able to run standard and guest network on both interfaces,

try disabling one of those cards (1st one), optionally move it to 5ghz band

Have tried that already.
Current setting is
Wifi 1: 2.4 Ghz / 20mhz
Wifi 2 : Disabled
/
I have tried also the switched option
Wifi 1 : Disabled
Wifi 2: 2.4 Ghz / 20mhz
/
Without change.

hmmm, I would try:

  • switching channel (try testing wifi analyzer around your house)
  • installing driver via reForis / Package Management / Packages / alternative core drivers

Remember, that 5GHz wifi card is connected to 5GHz antenna connectors at diplexers, so it is necessary to reconnect antenna cables to 2,4 GHz connectors at diplexers too when you are going to use this card at 2,4 GHz.

2 Likes

Don’t run the 1st adapter in 2.4GHz mode, run only as 5GHz.

Once I tried disabling the 2nd adapter and setting the 1st one as 2.4GHz, it had poor performance and was unstable.